GRUB 'no such partition found'


My problems all started when I updated my system and it automatically installed a new version of my GPU Driver (I’ve got a 1070 mini), but AFTER updating the Software-Store handed me a warning that this will brake the dependency to the old one even tough it was already installed and saying that it was to late for that message. I restarted the PC and it booted fine but there was like no GUI (just the blinking dot when loading the init frams but ttys worked). I tought like ok, that must be because of the GPU driver, let me delete the new one and install the old one tomorrow.
The next day I just got a message from grub (without even showing me the grub GUI) “no such partition found” and I got put in grub rescue. I tried to fix that setting up the boot sequences again as shown in a tutorial I found. When listing all drives (ls) i got everything I needed but when I tried to list partitions in a drive it again left me with the message “no such partition found” altough it seems to know that partition it cant find it (LOL).
Anybody got an idea how to fix that? I need that PC and tought manjaro would be a reliable OS to store my important data on it but currently I don’t think so anymore. If i cant reach my data in that particular machine i would loose about 150GB of important data .-.


boot into manjaro usb, connect to internet, open terminal, and run this:
sudo manjaro-chroot -a
then post output from:
test -d /sys/firmware/efi && echo efi || echo bios
mhwd-kernel -li && mhwd -l && mhwd -li
cat /etc/fstab

You do not loose your important data.

Thanks for the quick answer.
manjaro-chroot -a
gives me to grub-probe errors but then mounts dev/sdb1 wich is my linux device as i see so far.
it says bios wich is true. Kernels listed for the mhwd-kernel command thing:
linux510, linux515, linux516, linux517. I should be using 517 lately. cat /etc/fstab prints the /tmp and the / partition of my manjaro file and blkid actually seems to list two partitions that clearly belong to manjaro (“msods” and “Linux”). fdisk shows me one disk with Manjaro marked as boot.

This is the problem: you need to uninstall kernel 5.16 and 5.17.

Because they don’t exist anymore in Manjaro and obviously you don’t have the drivers for these non existent kernels.

Thank you, but how can I uninstall those kernel versions?

I would start by booting up the USB and backing up the important data. After that you can try to fix it, do some chrooting, or you can go for a fresh installation and restoration.

I don’t want to ask stupid questions, so I will assume you have something like Timeshift or a BackInTime scheduled to take system snapshots.

You can remove the kernels with
mhwd-kernel -r linux516 and mhwd-kernel -r linux517.

Thanks.Thats sad. The installation at least survived 1.5 years wich is longer than every windows i ever had but at this point I’m not sure if the problem is on the software layer, windows runs like sh*t and crashes (crashes are normal for win10 so i wont count that). But also first time booting the USB the kernel died after some time without showing anything the second time it loaded after like 5 minutes. I just can’t find out what part of the hardware might be broken .-.

I’m not using timeshift or something like that, I can’t afford the storage for backups ^^ Last time using timeshift with a single Disk System (garuada + btrfs.2) it just screwed the system after 2 month so I decided to just let that be.

copy the output of the commands here…
use formatting, click this icon in editor: </> and copy it there

For sure - I think the very least I’d want to have a disk I can plug in the USB port to get a backup off there…

What you can also do: boot with kernel 5.15 and remove kernel 5.16 and 5.17.
On console or with system manager (kernel).

1 Like

Well guys, I completely reinstalled manjaro after backing up my data and were still stuck with the same error. But I found out what actually happened, BIOS decided to change the boot-order and booted straight into my Data Disk for Win10, that still doesn’t explain why I’m getting the grub rescue line when booting to a fully NTFS formatted Disk and why that rescue cmd line is unfunctional but now manjaro seems to work again. Thanks for everybody helping me out on that one but sometimes its just a Layer 8 Problem (or a miracle) :wink: