Grub menu wont show on bootup. Cant find a solution after searching

I’m running the latest version of manjaro that I installed on an SSD where windows had installed its bootloader despite installing the rest of the system on my other HHD (I ******** hate windows so much). I thought this would be ok because I always get a Grub menu at boot any time I install a new distro, but it just boots directly into Manjaro.

I’ve tried updating grub and changing “hidden” to “menu” in the grub config file, but to no avail. Out of ideas here. ty

Welcome to the forum! :slight_smile:

You have to run… :arrow_down:

sudo update-grub

… after modifying /etc/default/grub. :wink:

thank you for the welcome!
i cant believe i didn’t try updating grub lol, my bad.

so grub shows up now except it hasn’t detected my windows install so I cant boot into it. Any ideas?

Can you post the output of… :arrow_down:

inxi -F

… please?

Note: Type two lines of three bacticks (`) each with an empty line in between them, and paste the output on the empty line. It makes the output more readable for us.

$ inxi -F
  Host: acab Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 2347A79 v: ThinkPad T430 
  serial: <superuser required> 
  Mobo: LENOVO model: 2347A79 serial: <superuser required> UEFI: LENOVO 
  v: G1ETC2WW (2.82 ) date: 08/07/2019 
  ID-1: BAT0 charge: 53.0 Wh condition: 65.3/93.6 Wh (70%) 
  Info: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP 
  L2 cache: 3 MiB 
  Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1197 4: 1196 
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
  Device-2: NVIDIA GF108M [NVS 5400M] driver: N/A 
  Device-3: Acer Integrated Camera type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.10 driver: loaded: intel 
  resolution: 1600x900~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.3.4 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  driver: snd_hda_intel 
  Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel 82579LM Gigabit Network driver: e1000e 
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 28:d2:44:44:09:9d 
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi 
  IF: wlp3s0 state: up mac: 3c:a9:f4:7e:24:bc 
  Local Storage: total: 585 GiB used: 48.12 GiB (8.2%) 
  ID-1: /dev/sda vendor: Seagate model: ST9500423AS size: 465.76 GiB 
  ID-2: /dev/sdb vendor: LITE-ON IT model: LMT-128L9M-11 MSATA 128GB 
  size: 119.24 GiB 
  ID-1: / size: 116.58 GiB used: 48.12 GiB (41.3%) fs: ext4 dev: /dev/dm-0 
  ID-2: /boot/efi size: 299.4 MiB used: 480 KiB (0.2%) fs: vfat 
  dev: /dev/sdb1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 47.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 3768 
  Processes: 212 Uptime: 26m Memory: 7.6 GiB used: 1.66 GiB (21.8%) 
  Shell: Bash inxi: 3.3.01

Have you tried… :arrow_down:

sudo grub-install && sudo update-grub


Also, this is perhaps an interesting read for you, depending on your situation… :arrow_down:

didn’t work :c

You can make grub appear holding either Esc, Shift or F8 during boot.

Edit /etc/default/grub and change to


Rebuild your grub.cfg

sudo grub-mkconfig -o /boot/grub/grub.cfg



Please, I had to register for this, remove the mac address info from your post(s); I mean, do yourself a favor. :slight_smile: