Grub menu does not show up


I have a dual boot with wn10 and everything is fine when I am connected to my TV screen.But this is not the case with a laptop screen which I am reusing (the laptop is dead and I am using a dedicated board found on the net that matches the screen).

The grub menu does not show up. It seems the board only detects the HDMI connection when systemd starts. Then it is ok with Manjaro.

But I have no choice. What can explain that the grub screen cannot be displayed?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

You can also use Maxi

to collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment

For example with maxi -g

Can you see Bios screen, at first power on, are you using UEFI or Bios Boot, Have you tried:

If your computer uses BIOS for booting, then hold down the Shift key while GRUB is loading to get the boot menu.

If your computer uses UEFI for booting, press Esc several times while GRUB is loading to get the boot menu.

Or do you mean the screen will not power up until later in the boot up sequence?

You can also check {root}etc/default/grub with a text editor and see what these 2 lines say:


The GRUB_TIMEOUT= will be a number, i think it might be 5 as default (5=5 seconds etc)
If it looks like the above then using root permissions edit it to:


Yes leave this blank after the = “GRUB_TIMEOUT_STYLE=”
Save file then update grub from terminal.

Thanks, I will try that. Actually I have to switch on the screen manually with this screen. And it will display a small window saying that an HDMI input is expected. This input does show up only when Manjaro starts, whereas I would expect it on boot, at least with Grub.

inxi --admin --verbosity=7 --filter --no-host --width                                       ✔ 
  Kernel: 5.15.38-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=d64f5d6a-3fa9-470b-a8a4-99c644107acb rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: ASUSTeK product: K30AM-J_A_F_K31AM-J v: 1004
    serial: <superuser required>
  Mobo: ASUSTeK model: K30AM-J_A_F_K31AM-J v: Rev 1.xx
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 1004
    date: 10/23/2015
  Message: No system battery data found. Is one present?
  RAM: total: 3.72 GiB used: 1.78 GiB (47.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Celeron J1800 bits: 64 type: MCP arch: Silvermont
    family: 6 model-id: 0x37 (55) stepping: 8 microcode: 0x838
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
    desc: d-2x24 KiB; i-2x32 KiB L2: 1024 KiB desc: 1x1024 KiB
  Speed (MHz): avg: 1333 min/max: 1333/2582 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 1333 2: 1333 bogomips: 9671
  Flags: 3dnowprefetch acpi aperfmperf apic arat arch_perfmon bts clflush
    cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept erms
    est flexpriority fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear mmx
    monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pclmulqdq pdcm pebs
    pge pni popcnt pse pse36 pti rdrand rdtscp rep_good sep smep ss sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq tsc_reliable vme vmx vnmi vpid xtopology
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
    vendor: ASUSTeK driver: i915 v: kernel ports: active: HDMI-A-1
    empty: DP-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0f31 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 337x270mm (13.27x10.63")
    s-diag: 432mm (17")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: HSP serial: <filter> built: 2012
    res: 1280x1024 hz: 75 dpi: 56 gamma: 1.2 size: 580x320mm (22.83x12.6")
    diag: 662mm (26.1") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: Mesa Intel HD Graphics (BYT) v: 4.2 Mesa 22.0.3
    compat-v: 3.1 direct render: Yes
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:0f04 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.38-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK H81M-C driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL88x2bu [AC1200 Techkey] type: USB driver: rtl88x2bu
    bus-ID: 1-1.4:4 chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
  IF: wlp0s20u1u4 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 596.18 GiB used: 60.92 GiB (10.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: HD321KJ
    size: 298.09 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: N/A serial: <filter> rev: 0-10 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS725032A9A364
    size: 298.09 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: C70E scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 298.09 GiB size: 292.35 GiB (98.07%)
    used: 60.92 GiB (20.8%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: d64f5d6a-3fa9-470b-a8a4-99c644107acb
  Alert: No swap data was found.
  ID-1: /dev/sdb1 maj-min: 8:17 size: 199 MiB fs: ntfs label: SYSTEM
    uuid: 9ADCFEB7DCFE8CAF
  ID-2: /dev/sdb2 maj-min: 8:18 size: 269.26 GiB fs: ntfs label: N/A
    uuid: 48402A1B402A106C
  ID-3: /dev/sdb3 maj-min: 8:19 size: 11.82 GiB fs: ntfs label: RECOVERY
    uuid: 01D572D5BDDB3D00
  ID-4: /dev/sdb4 maj-min: 8:20 size: 1 KiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-5: /dev/sdb5 maj-min: 8:21 size: 16.71 GiB fs: vfat label: DATA
    uuid: 980D-2B22
  ID-6: /dev/sdb6 maj-min: 8:22 size: 101.9 MiB fs: vfat label: HP_TOOLS
    uuid: 961B-F299
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: ASMedia ASM1074 High-Speed hub ports: 4 rev: 2.1
    speed: 480 Mb/s power: 100mA chip-ID: 174c:2074 class-ID: 0900
  Device-1: 1-1.4:4 info: Realtek RTL88x2bu [AC1200 Techkey] type: Network
    driver: rtl88x2bu interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
  Device-2: 1-2:3 info: Microsoft Wireless Desktop Receiver 3.1A
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 1.5 Mb/s power: 100mA chip-ID: 045e:00f1 class-ID: 0300
  Device-3: 1-3:5 info: YICHIP Wireless Device type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 3151:3020 class-ID: 0301
  Hub-3: 2-0:1 info: Super-speed hub ports: 1 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-1:2 info: ASMedia ASM1074 SuperSpeed hub ports: 4 rev: 3.0
    speed: 5 Gb/s power: 8mA chip-ID: 174c:3074 class-ID: 0900
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 169 Uptime: 20m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1449 pacman: 1433 lib: 396
  flatpak: 12 snap: 4 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.15

No. When I press F2, which should open the Bios/Uefi, my screen remains blue with the small window saying it expects an HDMI input.

It works on my TV screen, but not on the laptop screen. There is something about the board obviously, but what? as it is fine once Manjaro has started.

Sounds like something wrong hardware wise with the monitor or how ever it’s connect to the laptop, once you power on the Laptop it should send a wake up signal to the monitor, as it does over HDMI, The Bios does this first so it should already be power up before GRUB, Try re-seating all connections, check ribbon cable from the monitor is not bent or cut/broken, and last check the screen is really the right one for your laptop, the only other reason a monitor would not wake up from bios is if the monitor could not/does not run at said low resolution/refresh rate so stays blank until Manjaro Booting up changes the resolution to something the Monitor understand, you could try setting a low resolution once manjaro is on desktop, try setting 640x480 and see if the display blanks out.

You installed Manjaro in Legacy mode …

1 Like

Yes, my Windows is also legacy from the beginning and I am not sure I had the option. Does it make a difference regarding the display ? The question is also why does it work fine on my TV screen and not on the laptop screen?

In my case, the signal is sent after Manjaro has started.

Connectors are ok, cables also… I’ve tried different resolutions, but it does not help.