Grub-install fails during manual installation

I’m following this guide in order to manually install Manjaro with ZFS on root.

When running grub-install while chrooted, I receive the following error:

[root@manjaro /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro
Installing for x86_64-efi platform.
grub-install: error: failed to get canonical path of `/dev/usb-WD_BLACK_SN750_SE_1TB_21440T800632-0:0-part2'.

I suspect that I’m not properly (or fully) chrooted into the install on /mnt.

When I run:

  • manjaro-chroot /mnt /bin/bash

it works, but I get these errors/warnings:

/usr/lib/manjaro-tools/util.sh: line 262: /etc/lsb-release: No such file or directory
/usr/lib/manjaro-tools/util.sh: line 257: /etc/lsb-release: No such file or directory
/usr/lib/manjaro-tools/util.sh: line 267: /etc/lsb-release: No such file or directory
/usr/lib/manjaro-tools/util.sh: line 272: /etc/lsb-release: No such file or directory

Any idea what might be wrong?

manjaro-chroot script is a convenience script and requires the package lsb-release as the chroot tool relies on the info provided /etc/lsb-release.

You could just touch the file or you can install the package lsb-release

You can use chroot

chroot /mnt /bin/bash

Hi,
did you create the zpool which /boot resides with grub-compatible options?
Also, try to set the environmental variable as a workaround based on the instruction. The command would become:

ZPOOL_VDEV_NAME_PATH=1 grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro

If grub doesn’t work, you can also try systemd-boot.

This was it, I was missing ZPOOL_VDEV_NAME_PATH=1 in front of grub-install, that got everything going. Thanks a ton @dobedobedo! Fantastic guide too!

I tried the environment variable with grub-mkconfig like mentioned here, but didn’t think to use it with grub-install as well.

manjaro-chroot script is a convenience script and requires the package lsb-release as the chroot tool relies on the info provided /etc/lsb-release.
You could just touch the file or you can install the package lsb-release

@linux-aarhus I tried to do this, but didn’t succeed. Can’t run lsb-release -a either after installing the lsb-release package.

I suspect this may be a consequence of using alma as my installation medium of choice. I did this because manjaro didn’t come with ZFS modules, and I couldn’t find a way to install it on the LiveCD (other than maybe installing Manjaro on another USB stick).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.