Grub-install fails during Manjaro installation

I was trying to install Manjaro Gnome 20.2 on my Acer Spin 1 and grub will not install.

I get this error: screenshot

I’ve tried manual installing grub after and all I can do without errors is install without efi variables:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --no-nvram

but when I try to grub-mkconfig -o /boot/grub/grub.cfg or update-grub after that it finds a few images and then just does nothing and does not finish the process (I tried leaving it for a really long time).

Hello @aclear :wink:

An I/O error means that the filesystem is damaged or there is no space left. Most common issue is that the efi partition which is made by windows has no space left and therefore grub can not write.


Hello @megavolt, that does make sense but there is quite a bit of space on the parition, it’s 100MB and I have EFI partitions that are smaller that work just fine. Yes I do know (unfortunately with another one of my drives) that I/O could also mean it’s damaged but I believe this drive is good.