GRUB-install failing

I installed manjaro on my second drive (hdd), and the installation seems to be working fine, but the grub is not launching at restart.

My partitioning is as follows:

sda 8:0 0 119.2G 0 disk
├─sda1 8:1 0 260M 0 part
├─sda2 8:2 0 16M 0 part
├─sda3 8:3 0 118G 0 part
└─sda4 8:4 0 980M 0 part
sdb 8:16 0 931.5G 0 disk
├─sdb1 8:17 0 768.7G 0 part
├─sdb2 8:18 0 16.4G 0 part
├─sdb3 8:19 0 512M 0 part /boot/efi
├─sdb4 8:20 0 2G 0 part [SWAP]
├─sdb5 8:21 0 46.9G 0 part /
└─sdb6 8:22 0 97.1G 0 part /home
sdc 8:32 1 29.3G 0 disk
├─sdc1 8:33 1 3G 0 part
└─sdc2 8:34 1 4M 0 part

I’m getting the following error when I run grub-install /dev/sdb

grub-install: error while loading shared libraries: cannot open shared object file: No such file or directory

my zfs version output is this:


Hello @mji :wink:

On testing branch (i guess it is the same on stable) i get this:

$ LANG=C pamac search --files --no-aur
/usr/lib/ is owned by zfs-utils
/usr/lib/ is owned by zfs-utils
/usr/lib/ is owned by zfs-utils

So seems grub is searching for v2 while there is v4 available…

Maybe your system needs an system upgrade or maybe change to testing branch?

I would also assume that there was and upgrade of the zfs tools, but grub can’t handle v2 or maybe a simple symlink could solve this:

sudo ln -s /usr/lib/ /usr/lib/
sudo ln -s /usr/lib/ /usr/lib/

Since i never done a zfs setup… i could only suggest possible solutions… NOT TESTED

Hi, thanks for your help!

I got an identical output when I ran
$ LANG=C pamac search --files --no-aur

I searched my /usr/lib directory and it looks like isn’t in it at all, should I try to install an earlier version? or is there anyway for grub use the loaded instead?

Maybe a possible solution…

I guess without recompiling grub, itwill not work.

@Manjaro-Team Any ideas where the problem here is? Will there come an update for grub, so that it works with version 4 of the libs? :slight_smile:

Ooh, I think I found the issue. The tutorial I was following recommended grub-vanilla which doesn’t seem to be compatible with the newer versions. I uninstalled grub-vanilla and installed grub, and that seemed to resolve the error.

Thanks again!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.