GRUB INSTALL ERROR: Unknown filesystem

EDIT: What was the output of:

sudo cp -v /mnt/sda11/EFI/Manjaro/grubx64.efi /mnt/sda2/EFI/manjaro/

It was this
/mnt/sda11/EFI/Manjaro/grubx64.efi - - > /mnt/sda2/EFI/manjaro/

And manjaro entry is still not showing

Really running out of ideas here, and the partition layout seems complex for a dual-boot setup. :worried:

Just to rule something out, can you post the entire output of:

sudo smartctl -a /dev/sda

You can erase/hide the drive’s serial number before pasting it in here.

Prior to copying the .efi file,that made sense, since your esp partition (/dev/sda2) did not even have grubx64.efi. But it’s weird that pausing the boot process still does not list an extra entry.

A real concern is that grub-install cannot detect the file system of your root partition.

What is the ext4 file system under /dev/sda9 by the way? It’s not a separate boot partition?

sudo smartctl -a /dev/sda                                        ✔ 

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for manjaro: 
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.9.16-1-MANJARO] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke,

Device Model:     WDC WD10JPCX-24UE4T0
Serial Number:    **************
LU WWN Device Id: 5 0014ee 6b0b26dfd
Firmware Version: 01.01A01
User Capacity:    1,000,204,886,016 bytes [1.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5400 rpm
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-2 (minor revision not indicated)
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Fri Apr  2 16:31:11 2021 UTC
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(17940) seconds.
Offline data collection
capabilities: 			 (0x7b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					Offline surface scan supported.
					Self-test supported.
					Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 ( 201) minutes.
Conveyance self-test routine
recommended polling time: 	 (   5) minutes.
SCT capabilities: 	       (0x7035)	SCT Status supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     0x002f   200   200   051    Pre-fail  Always       -       201
  3 Spin_Up_Time            0x0027   180   176   021    Pre-fail  Always       -       1966
  4 Start_Stop_Count        0x0032   033   033   000    Old_age   Always       -       67694
  5 Reallocated_Sector_Ct   0x0033   200   200   140    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x002f   200   200   051    Pre-fail  Always       -       0
  9 Power_On_Hours          0x0032   081   081   000    Old_age   Always       -       14292
 10 Spin_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0
 11 Calibration_Retry_Count 0x0032   100   100   000    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   094   094   000    Old_age   Always       -       6167
192 Power-Off_Retract_Count 0x0032   200   200   000    Old_age   Always       -       217
193 Load_Cycle_Count        0x0032   102   102   000    Old_age   Always       -       294292
194 Temperature_Celsius     0x0022   108   094   000    Old_age   Always       -       39
196 Reallocated_Event_Count 0x0032   200   200   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   200   200   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   100   253   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       0
200 Multi_Zone_Error_Rate   0x0008   100   253   000    Old_age   Offline      -       0
240 Head_Flying_Hours       0x0032   082   082   000    Old_age   Always       -       13616

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Aborted by host               10%     14262         -

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

sda9 is an empty partition, its nothing in there

Something’s really up.

First off, /dev/sda11 shouldn’t even exist. It’s an extra FAT32 partition that is not flagged as the “esp”, which means your system does not scan it for EFI boot files when you power on.

Secondly, /dev/sda2 is FAT32 partition flagged as “esp”, which is where you get the Windows boot entry when you pause the boot process. (It happens to be your default EFI boot selection.)

For some reason, the manjaro folder under sda2’s EFI directory was empty.

But all of this should be fixed and at least restore a “manjaro” EFI boot entry when you try to re-install Grub from a live chroot session. (The fact that it boots directly into Windows can always be fixed from within your system/BIOS setup. The real problem is you can’t even override to boot into Manjaro’s Grub menu, since there is no “manjaro” EFI boot entry being detected.)

so does that mean i am screwed :sob:

This technically should have worked, only changing sda11 to sda2, and leaving the rest the same.

sudo su
mount /dev/sda10 /mnt
mount /dev/sda11 /mnt/boot/efi
cd /mnt
mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys
mount -o bind /dev /mnt/dev
mount -t devpts pts /mnt/dev/pts
chroot /mnt
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

I’m wondering why it failed.

You were using the latest ISO version of Manjaro to make that live USB?

no it was not latest…it was December 2020 ISO

and i am using ventoy…for multi iso

Do your steps using the latest.

Grub has been updated very recently.

Keep in mind not to use sda11, use only sda2 from now on.

okay , i think this will take time as my download speed is not that high…i may revert back tomorrow

Please do update us on how this works! :slightly_smiling_face:

1 Like

sure winnie…thank you for being there

can you

inxi -Mxa
test -d /sys/firmware/efi & & echo efi || echo bios
sudo efibootmgr -v
sudo parted -l
sudo lsblk -fs
sudo manjaro-chroot -a 
cat /etc/fstab 
exit ( end chroot )

@winnie @stephane

I reinstalled manjaro(in different partition), and now entry is showing in the grub menu(3 entries → 1 windows and 2 manjaro), i performed my commands i mention in topic and now its working fine,
just need to delete the newly installed manjaro partition and grub entry then i will be back to my original setup

thanks @winnie @stephane @linux-aarhus

What a trip, yeah? Even to this day, booting up a system still hasn’t reached the practicality of what an iPhone or Android phone offers: just turn it on and you’re good to go! Glad you got it back to a working dual-boot setup. Hopefully it’ll be smoother going forward since you’re all up to date. For future reference, simple partition layouts (with recent backups of your /home directory) will save you a headache or two down the line.

Thank you for updating us, @sonal! :v:

1 Like