Grub-install: Couldn't find boot partition mountpoint '/boot', check your /etc/fstab

Hello, I’m sorry if I’m distracting, but when I try to run the grub-install command, I get the following error: Couldn’t find boot partition mountpoint ‘/boot’, check your /etc/fstab.
it doesn’t matter what parameters i pass the error remains the same even if i try use help via -h/–help
I found this error after grub update . This topic has been partly discussed in [Unstable Update] 2023-02-17] (I’m not allowed to post links)
I use: btrfs, Linux kernel , efi, GUID Partition Table, GRUB 2.06.r456.g65bc45963-2,unstable branch (no problems until today)
i already tried manjaro-chroot from another distribution (not livecd),but it had no effect.

My fstab:

UUID=****                            /boot/efi      vfat    umask=0077 0 2
/dev/mapper/luks-**** /              btrfs   subvol=/"@",defaults,noatime,compress-force=zstd:5,autodefrag,space_cache=v2 0 1
/dev/mapper/luks-**** /home          btrfs   subvol=/"@"home,defaults,noatime,compress-force=zstd:5,autodefrag,space_cache=v2 0 2
/dev/mapper/luks-**** /var/cache     btrfs   subvol=/"@"cache,defaults,noatime,compress-force=zstd:5,autodefrag,space_cache=v2 0 2
/dev/mapper/luks-**** /var/log       btrfs   subvol=/"@"log,defaults,noatime,compress-force=zstd:5,autodefrag,space_cache=v2 0 2

at the moment the system is healthy, if you do not take into account this error and error: no such cryptodisk found. But I really want to understand the cause of the error, in the forums I could not find a suitable answer.
Thank for your attention.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Your boot partition is not at /boot but at /boot/efi.

You have no extra boot partition, that is re reason of this error. On BIOS/legacy you need a unencrypted boot partition so that the BIOS can boot it. Obviously the BIOS cannot handle the encryption, therefore grub does this. On EFI you need an unencrypted efi partition, that is what you have.

Maybe this error is more of a warning than an error?

You didn’t tell what parameters you use to install grub?

As I wrote earlier, the parameters do not affect the error, but if it helps I use:
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck , i also try --root-directory=/
unfortunately i couldn’t find a way to ignore this , so i think it’s a error

I understand this, but I have no idea how to force grub-install use this path

Well then fix it by creating an unencrypted boot partition (1 GB), which is mounted to /boot ? You can also use the EFI partition as /boot, but note that it have to be at least 1 GB, since it will also store the kernel images.

Maybe the grub script expects that there should be a boot partition and not only an efi partition?

Sorry, I researched the grub scripts, but couldn’t find your error message.

Well, thanks for the answer, but adding an additional, especially not encrypted partition does not suit me, because I intentionally left boot on the encrypted root

@philm Hello, I’m sorry to distract you, do you have any ideas to solve this problem?

We would think you might have chrooted wrong.
Can you write step by step here how did you chroot to Btrfs system on your encrypted partitions?

1)unlock luks partition
2) sudo mount -o subvol=@ /dev/mapper/luks-******* /mnt
3) sudo mount /dev/sdaY /mnt/boot/efi (sdaY - efi partition)
4) sudo manjaro-chroot /mnt
P.S: just in case you have questions manjaro-chroot -a doesn’t work with btrfs

Is there an error message?

I have done manjaro-chroot with my encrypted partition btrfs in the past, it should work.

I checked a part of your fstab:

Are your subvolumes "@"xxx, not @xxx ?

That is new for me. I tried to change them to "@"xxx in fstab in my KVM today, but mount failed at boot.

no, the error appears while executing sudo grub-install in manjaro-chroot
I used “@” because the site took it as a reference to users

If you “quote” your messages, the forum will not mistake them as reference to a user

UUID=****                            /boot/efi      vfat    umask=0077 0 2
/dev/mapper/luks-**** /              btrfs   subvol=/@,defaults,noatime,compress-force=zstd:5,autodefrag,space_cache=v2 0 1
/dev/mapper/luks-**** /home          btrfs   subvol=/@home,defaults,noatime,compress-force=zstd:5,autodefrag,space_cache=v2 0 2
/dev/mapper/luks-**** /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress-force=zstd:5,autodefrag,space_cache=v2 0 2
/dev/mapper/luks-**** /var/log       btrfs   subvol=/@log,defaults,noatime,compress-force=zstd:5,autodefrag,space_cache=v2 0 2

paste @what you want
will give:

paste @what you want

the original text was written with less text formatting and the site took @ as a reference, it seemed to me that there was no need to further clarify this, because when using “@” in fstab system will not be able to boot same as using *
I have read some comments on working with the forum, if in the future I need to issue a message, I will definitely do it more carefully

Can someone who uses btrfs,EFI and has grub-install working send me the contents of their fstab ? With the version of grub

So you use cryptboot from the AUR? Then it would explain this message, but it is not a grub-install problem then.

Darn it, you’re right, I must have experimented with security a long time ago and forgot this package in my system.
I have even read several manuals on grub and efibootmgr, but I did not even expect that the package from aur would change the grub-install behavior , thank you very much

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.