GRUB : dualboot with Zorin OS


I’m using Manjaro KDE since a few months now and i’ like to test (for fun) others distros on my PC.

So i installed Zorin OS (btrfs), which is based on Ubuntu. I used Gparted in Zorin OS live to resize my main partition. I installed Zorin without grub, in terminal with “ubiquity-b”.
I restarted manjaro and i verified GRUB_DISABLE_OS_PROPER=false was uncommented. Then i used “sudo update-grub”

Zorin OS seems to be detected:

Création du fichier de configuration GRUB…
Thème trouvé : /usr/share/grub/themes/manjaro/theme.txt
Image Linux trouvée : /boot/vmlinuz-6.1-x86_64
Image mémoire initiale trouvée : /boot/amd-ucode.img /boot/initramfs-6.1-x86_64.img
Found initrd fallback image: /boot/initramfs-6.1-x86_64-fallback.img
Image Linux trouvée : /boot/vmlinuz-5.15-x86_64
Image mémoire initiale trouvée : /boot/amd-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Attention : le sondeur de systèmes d’exploitation sera exécuté pour détecter d’autres partitions amorçables.
Sa sortie sera utilisée pour détecter les binaires amorçables qu’elles contiennent et créer de nouvelles entrées d’amorçage.
Zorin OS 16.2 trouvé sur /dev/nvme0n1p3
Ajout de l’entrée du menu d’amorçage pour les paramètres du firmware UEFI …
Detecting snapshots …
Found snapshot: 2023-02-05 13:02:30 | timeshift-btrfs/snapshots/2023-02-05_13-02-30/@ | boot | N/A |
Found snapshot: 2023-02-05 13:00:01 | timeshift-btrfs/snapshots/2023-02-05_13-00-01/@ | boot | N/A |
Found snapshot: 2023-02-05 11:00:01 | timeshift-btrfs/snapshots/2023-02-05_11-00-01/@ | daily | N/A |
Found snapshot: 2023-02-05 10:00:05 | timeshift-btrfs/snapshots/2023-02-05_10-00-05/@ | boot | N/A |
Found snapshot: 2023-02-05 10:00:02 | timeshift-btrfs/snapshots/2023-02-05_10-00-02/@ | boot | N/A |
Found snapshot: 2023-02-05 01:39:44 | timeshift-btrfs/snapshots/2023-02-05_01-39-44/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found snapshot: 2023-02-04 11:00:01 | timeshift-btrfs/snapshots/2023-02-04_11-00-01/@ | daily | N/A |
Found snapshot: 2023-02-03 11:56:07 | timeshift-btrfs/snapshots/2023-02-03_11-56-07/@ | ondemand | N/A |
Found snapshot: 2023-02-03 10:15:32 | timeshift-btrfs/snapshots/2023-02-03_10-15-32/@ | boot | N/A |
Found snapshot: 2023-02-03 10:02:44 | timeshift-btrfs/snapshots/2023-02-03_10-02-44/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found snapshot: 2023-02-03 10:00:12 | timeshift-btrfs/snapshots/2023-02-03_10-00-12/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found snapshot: 2023-02-03 10:00:02 | timeshift-btrfs/snapshots/2023-02-03_10-00-02/@ | daily | N/A |
Found snapshot: 2023-02-02 08:00:01 | timeshift-btrfs/snapshots/2023-02-02_08-00-01/@ | daily | N/A |
Found snapshot: 2023-02-01 10:00:01 | timeshift-btrfs/snapshots/2023-02-01_10-00-01/@ | weekly | N/A |
Found snapshot: 2023-01-31 17:28:01 | timeshift-btrfs/snapshots/2023-01-31_17-28-01/@ | daily | N/A |
Found snapshot: 2023-01-24 20:17:50 | timeshift-btrfs/snapshots/2023-01-24_20-17-50/@ | weekly monthly | N/A |
Found 16 snapshot(s)
Unmount /tmp/grub-btrfs.AfjwfLOhm7 … Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe : attention : type de périphérique nvme0n1 inconnu.
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
/usr/bin/grub-probe : attention : type de périphérique nvme0n1 inconnu.

But when i reboot, Zorin OS doesn’t appear in grub…

Thanx in advance for your help.

Manjaro uses a customized version of GRUB. Have you tried restoring GRUB? Here is a helpful guide:

I tried restoring, but no Zorin OS in grub options after reboot…

If you want to test other distributions, I strongly recommend that you do so by running them as virtual machines, using your Manjaro as the host. VirtualBox is excellent for this, and the learning curve isn’t too steep. You do need a fairly strong cpu, I recommend at least an I5 or equivalent and at least 8GB of ram so you can split the ram 50-50 between your host and virtual machines. Any time you are installing multiple distributions you are messing about with your partitioning and with grub, which has a bunch of pitfalls that aren’t there with virtual machines. If you mess up your VM, it can be deleted with a couple of mouse clicks, and there is a snapshot option in the VB Manager to reload an older VM if you happen to mess up one that has been working.
Assuming both your Manjaro and your Zorin are installed uefi, you can try installing rEFInd on your working Manjaro and see if it picks up your Zorin boot files. Read the rEFInd manual before you install.

Ok thanx I’ll try with VM!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.