Grub broken after latest stable update [2021-05-19]


My name is Michal, I’m new here. I’ve been using Manjaro KDE Plasma for the last 2 months. I had some problems with dual-boot installing but could manage everything thanks to this forum.

I made an update of my OS yesterday. Since today I cannot boot Manjaro nor Windows anymore. First, I could only see the option to boot into Windows in grub.
Later on, during the day when I was trying to fix it, the whole grub disappeared and my only option is to use a live USB. Inside the UEFI/ General / Boot Sequence, I can see manjaro listed there but cannot run it. It won’t boot. Before it broke down I didn’t see it there in UEFI settings but could see it listen with Windows in the grub menu.

I’m kind of stuck now, I don’t know what to do. I’ve tried things that helped others but not me.
After I followed this tutorial by Chris on Youtube which I cannot link to this becuase I don’t have rights for some reason I found that I don’t have any images listed there only the memtest86 image.

If you can guide me I can provide more information about my laptop. I’d like to solve this issue asap because it’s my work laptop and I need to use it on daily basis.


[manjaro@manjaro ~]$ sudo parted -l
Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sda: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
2      2498MB  2502MB  4194kB  primary               esp

Model: Micron 2200S NVMe 512GB (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB  16.8MB               Microsoft reserved partition  msftres
 3      123MB   303GB  303GB                Basic data partition          msftdata
 5      303GB   512GB  209GB   ext4
 4      512GB   512GB  522MB   ntfs                                       hidden, diag

[manjaro@manjaro ~]$ sudo lsblk -fs
NAME      FSTYPE    FSVER            LABEL             UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0     squashfs  4.0                                                                           0   100% /run/miso/sfs/livefs
loop1     squashfs  4.0                                                                           0   100% /run/miso/sfs/mhwdfs
loop2     squashfs  4.0                                                                           0   100% /run/miso/sfs/desktopfs
loop3     squashfs  4.0                                                                           0   100% /run/miso/sfs/rootfs
sda1      iso9660   Joliet Extension MANJARO_KDEM_2021 2021-01-03-09-41-14-00                              
└─sda     iso9660   Joliet Extension MANJARO_KDEM_2021 2021-01-03-09-41-14-00                     0   100% /run/miso/bootmnt
sda2      vfat      FAT12            MISO_EFI          0278-AA6D                                           
└─sda     iso9660   Joliet Extension MANJARO_KDEM_2021 2021-01-03-09-41-14-00                     0   100% /run/miso/bootmnt
nvme0n1p1 vfat      FAT32                              2477-81BD                                           
nvme0n1p3 BitLocker 2                                                                                      
nvme0n1p4 ntfs                                         4E6A30DD6A30C38D                                    
nvme0n1p5 ext4      1.0                                bebc5cfd-1c63-4064-9780-e7ca1398dec1                
[manjaro@manjaro ~]$ 

[manjaro@manjaro ~]$ sudo manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
==> Detected systems:
 --> 0) ManjaroLinux
==> Select system to mount [0-0] : 
==> Mounting (ManjaroLinux) [/dev/nvme0n1p5]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]

[manjaro /]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=2477-81BD                            /boot/efi      vfat    umask=0077 0 2
UUID=bebc5cfd-1c63-4064-9780-e7ca1398dec1 /              ext4    defaults,noatime 0 1
/swapfile none swap sw 0 0

[manjaro /]# efibootmgr -v
BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0001,0003,0004,0005,0006
Boot0000* Windows Boot Manager  HD(1,GPT,d08eba46-b2cb-4f67-9f99-bbae2369fbac,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...T................
Boot0001* manjaro       HD(1,GPT,d08eba46-b2cb-4f67-9f99-bbae2369fbac,0x800,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot0003* Onboard NIC(IPV4)     PciRoot(0x0)/Pci(0x1f,0x6)/MAC(a4bb6de9c7f0,0)/IPv4(,0,0)..BO
Boot0004* Onboard NIC(IPV6)     PciRoot(0x0)/Pci(0x1f,0x6)/MAC(a4bb6de9c7f0,0)/IPv6([::]:<->[::]:,0,0)..BO
Boot0005* UEFI: KingstonDataTraveler 3.0PMAP    PciRoot(0x0)/Pci(0x14,0x0)/USB(19,0)/CDROM(1,0x4a7104,0x8000)..BO
Boot0006* UEFI: KingstonDataTraveler 3.0PMAP, Partition 2       PciRoot(0x0)/Pci(0x14,0x0)/USB(19,0)/HD(2,MBR,0x0,0x4a7104,0x2000)..BO
1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. Try to repair grub using chroot first and if that doesn’t work, provide the above while booted from USB.


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time


Thanks for the reply. I tried to repair grub using chroot. It didn’t help.

I solved my problem by installing a new kernel. I was missing the kernel in my system after updating it. I assume I had to accidentally uninstall it after I did the update because I remember I had some colliding dependencies.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.