Grub bootloader fails to install

So basically, I’ve had an old laptop lying around for 2 weeks (specs will be given if needed), and decided to try and put Manjaro XFCE on it so I can finally get into Linux in some way. So I did what anyone would, booted from my usb into Manjaro, clicked on the installer, and went through. When the installer reaches 90% (aka the bootloader part), it gives this error:

The bootloader could not be installed. The installation command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force
returned error
code 1.

I tried to get help on Reddit, but it didn’t really fix anything. I’ve tried to make manual partitions multiple times, even tried to use Xubuntu to make sure it wasn’t an issue with Manjaro, and it also said the same error.( side-effect of this was that I think I managed to get a version of ubuntu on the drive somehow, but that isnt an issue) I tried to manually repair grub with terminal, but it didn’t work.
My system is UEFI, I’ve already disabled secure boot and everything related to legacy.

so use ventoy to flash iso on usb, and boot it in uefi and run the installation with:
sudo calamares -d

1 Like

I flashed the iso onto the usb with ventoy, booted into manjaro and ran the installation with command you gave me but it still failed.

well you should post the output from the error in terminal …
is the hard disk unmounted when you try to install onto it?
also check this list:

Firmware checklist for BIOS systems

  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable EFI
  • :white_small_square: Disable RAID option
  • :white_small_square: Enable AHCI

Firmware checklist for EFI Systems

  • :white_small_square: Disable CSM (Legacy) boot
  • :white_small_square: Disable Secure Boot
  • :white_small_square: Enable AHCI
  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable Optane Memory and Rapid Storage Technology (RST)
  • :white_small_square: Disable RAID option
  • :white_small_square: Disable Fast Boot (if unable to boot from USB)

This is the output it gave me: 19:31:02 [6]: virtual Calamares::JobResult Calamares::PythonJob::exec() Job -
And about the firmware checklist. I’ve disabled CSM I believe, disabled secure boot, disabled fast boot. All the other things (AHCI, Optane Memory, RST, RAID) arent in my bios.

do you boot ventoy in uefi mode, and is the partition on which you want to install unmounted?

I boot ventoy in uefi mode, I’m not sure if the partition I want to install on is unmounted or not, how can I check?

run this command: lsblk -f and the mount column should be empty

Output of the command: [manjaro@manjaro ~]$ lsblk -fNAME FSTYPE FSVER LABEL UUID -

can you post output from: efibootmgr -v and:
test -d /sys/firmware/efi && echo efi || echo bios

Apologies for the late reply but here:

looks ok… i would delete the whole disk, including the fat32 partition, create again GPT file sytem table, reformated it again in ext4 and tried again installing

should i use gparted to delete the whole disk then?

i dont know whats the default disk management app in xfce, but if its gparted than use it, delete the whole disk, create new GPT table, format it in ext4 and try install

I checked the gmsmartcontrol app in the live desktop, and it says there’s 156 ATA errors, is that bad?

well its probably not good… did you run the check before deleting/creating GPT/formating or after? if before, try to delete the disk and run it again, if you still get errors can you post the output of those errors