Grub and BIOS don't show up after the installation

I have a system with SSD and HDD. Windows is installed in the SDD and HDD is for data. In the last disk is where I installed Manjaro.

I created 4 partitions:

/, /home, swap and /boot/efi (the installer was the one who pointed out the need for that partition).

After the installation I rebooted the pc but grub didn’t show up, and the Windows system started.

I rebooted again to try to enter the BIOS, but now the BIOS doesn’t show up. It is just a black screen with a “_” in the upper left corner of the screen.

I don’t know much about linux. So is there a way to fix this? I don’t care losing the Linux system, I just want the BIOS to show up again.

My pc is an Acer Nitro 5, btw.

  1. You do not have a BIOS: you have an UEFI system

  2. Although it is possible to have multiple ESPs, you need to always pass through the UEFI firmware to boot the second ESP.
    So unfortunately, if you want grub to show up, you have to mount the existing ESP when installing, which means you’re in for a reinstall.

  3. I have an Acer too and you have to:

    • Shut down
    • Turn the system on
    • start pressing F2F2F2F2F2F2F2F2F2F2F2F2F2F2F2F2F2 the moment the screen turns on until you’re back into the UEFI settings.


  • start pressing F2F2F2F2F2F2F2F2F2F2F2F2F2F2F2F2F2 the moment the screen turns on until you’re back into the UEFI settings.

Thanks, but I already tried that. As I said in the post, it just shows me a black screen with a no blinking cursor at the upper left corner. The systems gets stuck there and I can’t do anything. I have try pressing some keys but nothing works. The only thing I can do is to power off the pc and start again.
I also try getting to the UEFI directly from Windows, but it also takes me to that black screen.

Unfortunately, you only have 2 options left:

  • Return the system to Acer for maintenance
  • Disassemble the system:
    • Remove the main battery
    • Remove the NVRAM battery,
    • “Turn on” the system (I.E. press the power button)
    • reassemble the system.

This is not a Manjaro problem but a hardware problem and the reason my current Acer is the first and last system of that brand I’ll ever buy…


I think I will return the system for maintenance.


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

I don’t disagree with your solution, however I’ve searching the problem and I found this:

Personally, I don’t know if I’m going to try them. I’m afraid of doing something wrong and just make things worse. But anyway, I leave the solutions so people with the same problem can try them.
It seems fast boot and secure boot needs to disabled.

Solution removed. Sorry for not mentioning this as a first, but yes, secure boot needs to be turned off or the Manjaro EFI file needs to be added to your EFI signature list, but that’s a hardware issue, not a Manjaro issue: that’s a first before you install anything other than Windows…

(Monopoly and all that)

You also need to turn off Windows hybrid hibernate in a dual boot.


Hi, I found this another solution:
One of the answers pointed out this link:

In the article, it says:

The GRUB files for the distribution that was installed will be under a folder of the same name as the distribution. For example, if Ubuntu was installed, as in this example, the name of the folder will be ubuntu.

However, in that step I get this: Boot, Microsoft, OEM
There is no Manjaro folder. Is OEM the folder that contains Grub and the one I have to delete? Or I have to follow other steps?

You don’t seem to have a Manjaro problem but an UEFI problem, so can you provide screenshots of your UEFI Boot settings (picture taken from phone is OK).


I was able to solve the problem by resetting the battery with the power button. I’m not going to try again to install linux on this computer though. At least not in the internal drive.

Nowadays, with UEFI that doesn’t protect you any more: settings are stored in NVRAM and the ESP.

Read the UEFI manual that came with the computer. Having 2 ESPs is possible, but even more complex than what you just tried.


P.S. And Acer is particularly shìte bad with UEFI: twice per year, Windows updates reset my NVRAM to default and I have to rescue my grub… First and last Acer I’ve ever bought!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.