Grml-zsh configuration

Hope this is the right place for it.

I check on the internet, cant find it. How can i install/configure grml-zsh-config ? Zsh was a bit problematic, “command not found: compinit” stuff at startup and such. Tried oh-my-zsh it was kinda worse and people said dont use it, its complex and complicated.

Its fresh install of zsh and after installed grml-zsh. Yes tab surfing is on now (even i didnt add it :slight_smile: i loved it, its kinda auto. Zsh has no config now, oh-my-zsh i uninstalled it -hopefully i managed it without nothing left-)

I still have .bash files but gladly, zsh and oh-my-zsh conf is denied and replaced by grml-zsh. How can i know ? From the prompt. But not fully and properly.

Find something like this: “
I have non of those files.

From - Zsh :

Tip: for Archlinux linux users exists an official grml-zsh-config package.

So…the repositories? Or AUR?

Umm… Repositories. What do you mean by that tip ?

@Mirdarthos hope you there, im struggling for days with a few problems. And my project distrupted. I installed already but didnt configured well.

Sorry. Just came back and saw your message.

There are 2 place you can install software from on Manjaro (actually, I think more, but that is a rabbit hole I’m not going into):

  • The AUR, which is by other users and not at all official; and
  • the official repositories. Now these contain packages maintained, so vetted by Team Manjaro, and thus officially supported.

I just checked, and grml-zsh-config is in the extra repository:

$ pamac search grml
grml-zsh-config  0.19.6-1                                                                                                                                                                                                                               extra

…so it can easily be installed with:

pamac install grml-zsh-config

Also, familiarise yourself with the installation of software, it’ll save you many headaches in the future:

Hope this helps!

Oh yes, i installed it. But i didnt configured out. Like i said, o have still zsh on. So im guessing i cant delete zsh because its installed on zsh right ? At least im still using zsh. How can i check is grml-zsh-config on or not ? And can i delete bash now ? I dont want them to conflict.

Don’t do that. It is an integral part of the system. Don’t worry, it won’t conflict. You can remove zsh if you want to, but I can’t help you there, since I installed mine a long time ago, before it came preinstalled and default and haven’t touched it since.

I also know nothing about grml, or grml-zsh-config obviously, but I don’t think it clashes with zsh. Rather, I think it uses zsh. But I can’'t help you, since I don’t know it. You’ll have to check its website for instructions:

1 Like

You can install grml-zsh-config using the command below. It will conflict with manjaro-zsh-config - accept the removal and you are done.

sudo pacman -S grml-zsh-config

Don’t delete bash - a lot of shell scripts relies on bash - there will be no conflicts - they are simply shells.

Demonstrating the grml-zsh-prompt - running zsh from a bash shell

13:37:08 ○ [fh@tiger] ~
 $ zsh
fh@tiger ~ % cd /a/projects/nest-nixrepo/forgejo 
fh@tiger /a/projects/nest-nixrepo/forgejo (git)-[forgejo] %
1 Like

Yes i had doubt on bash may be essential and it is. I tried to uninstall zsh but it appears its needed for grml-zsh-config. There is my prompt (i guess its still using zsh i would say but its changed, i guess conf issue or not fully configured):

1 guns@roses ~ %                                                      :(

That ‘1’ is appears for failure command. Its also has sad face but yeah numbers also somehow included. Its looks kinda broken huh ?

To be fair, it’s right there in the name…

Quite possibly…

It does. I think there is a font still missing…but can’t say for sure or which it is…


What’s the output of:

ls -l /etc/skel/.config/

Its empty. /etc/skel/ is exist but there is no .config in there:

guns@roses ~ % ls -l /etc/skel/.config/
ls: cannot access '/etc/skel/.config/': No such file or directory
guns@roses ~ % cd /etc/skel 
guns@roses /etc/skel % ls -a
.  ..  .bash_logout  .bash_profile  .bashrc  .zshrc

Thank you for caring tho. Im stuck with that.

:face_with_raised_eyebrow: but I have NO idea further, then. Sorry.


I guess you found the source of problem.

1-) Yes i have a font problem. Im using sway, i was not able to list the font loaded which used by sway.
Its installed but not loaded. Terminal font set to Ubuntu Mono. * Which is also sway suppose to use (its set in sway conf)
Windows titlebars are using different font than Ubuntu Mono too.

2-) Is there a chance zsh missing install/configuration problem ? When i first install zsh i configured, its added ‘-compinit’, ‘-autoload -Uz compinit’ and 2 more commands in .zshrc file.
Which is throwing me errors in tty ‘unkown command’, thats why i deleted thoose lines. And reinstall with no configuration at all. No settings applied, zsh hardly recommend to define/configure settings. .zshrc only has color commands.

I’d show you mine, but it’s not default for a long long time.

Honestly, I don’t kn0ow where to go or what to do here…

1 Like

Better than nothing, i guess…


You do not have to use grml/Debian to use grml’s zsh configuration. Just retrieve and install the configuration files in your home directory via executing for example:

# IMPORTANT: please note that you might override an existing
# configuration file in the current working directory! =>
wget -O .zshrc

# Optionally also grab the user configration:
# wget -O .zshrc.local

Excellent, but it didnt changed my prompt. I deleted the .zshenvBackup (might be that) and .bashrcBackup (.bashrc still exist) but nope still same prompt.
My files:
.bashrc .bash_logout .bash_profile .zcomdump(i dont know its related or not) .zdirs .zshrc .zsh_history
Is it some file missing ? I realize the warning of dont override it so deleted the .zshrc and wget again but same… Its some bash/zsh problem i guess, i was not gonna pacman -Syu update but for 3-4. try it did

EDIT: Its broken, what commands can i run for validate/verify ? Like i mentioned in my other posts the problem may be about missing fonts or misconfiguration.

guns@roses ~ % which zsh
guns@roses ~ % zsh
guns@roses ~ % 

Any solutions ? Do i need to run a command ? Load profile, zsh conf make or etc. ?