Greetd and power management issue

First of all, thanks for the amazing work form Manjaro ARM team ! I’m running Manjaro Vim2 Sway 21.08 on a legacy Amlogic gxbb s905 Tv box . It correctly recognized 2k@70 resolution and glxgears got an average 35fps result :smiley:

Other than that, there are still some minor issues that could be polished .

1. /etc/greetd/config.toml wrong user

In /etc/greetd/config.toml, user is left to oem which is supposed to be replaced with actual user name. This results the failure of greetd, which keeps user out of desktop environment.

2. Power management issue

It seems that Manjaro ARM 21.08 could not recognize “poweroff” “shutdown” signals correctly ,which results system reboot instead . Further more , after the monitor is auto turned off at sleeping stage , I could not light it up from TTY1 unless I unplug the HDMI cable and plug it back.

These issues are by no means urgent nor serious, just pointed out of curious.

As mentioned yesterday by @Strit there has been a bugfix for the calamares oem installer the other day, which will properly remove the oem settings from the greetd config file at the end of the initial setup procedure…

So best would be to remove everything from the config.toml related to the initial session:

command = "sway --config /etc/greetd/oem-setup"
user = "oem"'
1 Like

This is wired as the buttons in the log out overlay are clearly running the proper systemctl commands: overlays/sway/etc/skel/.config/wlogout/layout · master · manjaro-arm / applications / arm-profiles · GitLab

We may need additional kernel or systemd logs to clarify this.

Before kernel 5.14 (in testing branch at the moment) recognizing an external display took some seconds on my Pinebook Pro as well. Now it turns on instantaneously. Might be worth checking with a newer kernel version…

1 Like

Seems the power management issue is related to amlogic legacy bootloader .I installed linux-rc yet still could not wake up my monitor without replug hdmi cable. Maybe I shoud grab a GT King Pro or Firefly Station P2 which is up to date :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.