Green With Envy - Fan profile don't active

Hello everyone. Can you please tell me how can activate the “Fan Profile” section in order to change the curve of the coolers on the video card? Until recently, on Windows, I did this using MSI Afterburner, but on Linux I found only the Green With Envy program, launched it, and the profile was locked. Why? What can I do for fix this problem?
Thank you so much guys for any help!

Hello and welcome

You have to add to /etc/X11/mhwd.d/nvidia.conf under the Device section this entry:
Option "Coolbits" "8"
as per gwe application message:

image

Im sorry, but that option didn’t help :frowning:

Probably you can share the /etc/X11/mhwd.d/nvidia.conf
I’ll try it later on this evening.
Maybe @schinfo can shade some light about this, and if is a new issue if there is a fix. Thanks!

Of course!

Thank you too!

I try to change fan profile in this program

Please do not share screenshots of configuration files. Edit your post, copy the text and use </> icon to properly format it, or ``` above and bellow it.

1 Like

if i recall you need 8 to overclock and 4 to set fan profile so coolbits needs to be 12.

see first item in the faq

1 Like

Sorry. I’ll know it.

Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    	Option "NoLogo" "1"
    	Option "Coolbits" "8"
EndSection

I’m very happy! - everything worked.
Option “Coolbits” “12” helped me.
To everyone who tried to help me, I express my deepest gratitude!
Close topic please and have a nice day :slight_smile:

Normally it should be automatically set to “31” during installation.
So all functions are activated.
The question is how GWE was installed.

If the Manjaro version was not used, it will not run.
The cause is whwd and therefore the conf file is in a different directory.
Section is although "Screen"

gwe.install

post_install()
{
## patch /etc/X11/mhwd.d/nvidia.conf
grep -q 'Coolbits' /etc/X11/mhwd.d/nvidia.conf
if [ ! $? -eq 0 ]; then
	sed -e '/Section "Screen"/a\' -e '    Option         "Coolbits" "31"' -i /etc/X11/mhwd.d/nvidia.conf
fi
}

post_upgrade()
{
post_install
}
3 Likes

I’ll have to check as i switched from 440.xx drivers when gwe had the profile creation active, to 450.xx drivers and i did not reinstalled gve trough pamac.
Thank you for clarifying this. Also i think you provided the actual solution for this topic.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.