Grdctl vnc server not listening on 5900

I was trying to set up a vnc server on manjaro/GNOME, for which I choosed gnome-remote-desktop following the GNOME wiki, as it seems to require the least tinkering.

But after setting up

$ grdctl vnc disable-view-only
$ grdctl vnc set-password 123456
$ grdctl vnc enable
$ grdctl status
RDP:
    ....
VNC:
    Status: enabled
    Auth method: prompt
    View-only: no
    Password: (hidden)

the vnc port (5900) does not seem to be listened on:

$ sudo lsof -i -P -n | grep LISTEN | grep 5900
(nothing)

This issue has been reported in the forums of many other distros but remains basically unanswered.

So, is grdctl supposed to function at all? If so, is port 5900 supposed to be listened on when it’s functioning?

5900 may not be available - try 5901 instead

there’s a few sshd/dockerd listening but no 59?? at all :frowning: