Graphics driver not working after Windows installation - nvidia

I’ve been using Manjaro for a few months in my PC without any problems. However, I had to install Windows for some work-related software, so I bought a separate SSD and installed Windows on it. After that, my Manjaro system began halting on a black screen when booting. I can get into tty, but running startx gives the error:

   Fatal server error:
    [407.955] (EE) no screens found (EE)
    [407.955] (EE)

Calling nvidia-smi gives this error (this seems to be the core issue, but I’m stumped on how it could have arisen):

    NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I tried booting from a Manjaro live USB and that worked fine, which prompted me to try and install the new Nvidia graphics drivers. However, running “sudo mhwd -a pci nonfree 0300” gives the error

    Error: config 'video-nvidia-455xx' conflicts with config(s): video-nvidia-418xx

Attempting to uninstall the current 418 driver first gives

> Removing video-nvidia-418xx
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-418xx/MHWDCONFIG
Processing classid:0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux57-nvidia-418xx breaks dependency 'linux57-nvidia-418xx' required by linux-latest-nvidia-418xx
Error: pacman failed!
Error: script failed!

Any advice on how to proceed, whether by fixing the driver communication issue or properly installing the latest drivers, would be greatly appreciated.

Edit: Here’s the output from inxi -Fazy (from the live USB since I can’t copy and paste from tty). The installed system is still on kernel 5.9

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_XFCE_202 quiet systemd.show_status=1 
  apparmor=1 security=apparmor driver=nonfree nouveau.modeset=0 i915.modeset=1 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: ROG CROSSHAIR VIII HERO (WI-FI) 
  v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 0702 
  date: 07/04/2019 
  ID-1: hidpp_battery_0 charge: N/A condition: N/A volts: 3.8/N/A 
  model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A 
  serial: <filter> status: Discharging 
  Info: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 124621 
  Speed: 2795 MHz min/max: 2200/3900 MHz boost: enabled Core speeds (MHz): 
  1: 2793 2: 2792 3: 1924 4: 1926 5: 1863 6: 2796 7: 1861 8: 1858 9: 1859 
  10: 1859 11: 1861 12: 2794 13: 1861 14: 1862 15: 2795 16: 2660 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  always-on, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: ASUSTeK 
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 0b:00.0 
  chip ID: 10de:1e07 
  Display: x11 server: X.Org 1.20.10 driver: nvidia display ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.7x13.4") 
  s-diag: 692mm (27.2") 
  Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 163 
  size: 597x336mm (23.5x13.2") diag: 685mm (27") 
  OpenGL: renderer: GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
  Device-1: NVIDIA TU102 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0b:00.1 chip ID: 10de:10f7 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0d:00.4 chip ID: 1022:1487 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel 
  port: e000 bus ID: 05:00.0 chip ID: 10ec:8125 
  IF: enp5s0 state: down mac: <filter> 
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel 
  port: d000 bus ID: 06:00.0 chip ID: 8086:1539 
  IF: enp6s0 state: down mac: <filter> 
  Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: d000 
  bus ID: 07:00.0 chip ID: 8086:2723 
  IF: wlp7s0 state: up mac: <filter> 
  Local Storage: total: 738.69 GiB used: 706.9 MiB (0.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 PRO 512GB size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 1B2QEXP7 scheme: GPT 
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 250GB 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 2B2QEXM7 scheme: GPT 
  ID-3: /dev/sda type: USB vendor: SanDisk model: Cruzer size: 28.86 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: PMAP 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 11.71 GiB used: 706.9 MiB (5.9%) fs: overlay 
  source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 41 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33% 
  Processes: 368 Uptime: 3m Memory: 15.61 GiB used: 1.64 GiB (10.5%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1158 lib: 324 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.08 

Try removing this package with sudo pacman -R linux-latest-nvidia-418xx first, then install the new driver.

In addition, linux57 is EOL. I recommend removing EOL kernels.

Thanks, this worked. I will keep this in mind.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.