Graphical Artifacts on Live/Installed/Updated KDE Manjaro

Hello all! I recently bought a new laptop, and upon booting from the live USB I created, I noticed that it has some graphical artifacting that occurs whenever I move my mouse around. It almost seems to be at specific positions as the artifacting will remain in place until I shift my cursor away from that position, and so I was hoping to ask for some assistance in what might be occurring? I’ve tried the live USB, post-install after a reboot and removal of the drive, and post-install after updating (pacman -Syu). I’ve seen posts about optimus-manager, but they seem to go to the archive forums which I’ve not been able to access, and so I’m uncertain if doing something with that considering the laptop having both Nvidia and Intel here would be the cause, or if there may be something else worth looking into. I’ve also tried upping the kernel to 6.08 to see if that would be helpful, but I run into issues that probably warrant a second topic.

I’ve attached the inxi output as mentioned, and hopefully did so correctly; if there’s any more information that may be needed, please do let me know and I would be happy to provide it! Thank you for any and all help!

  Kernel: 5.15.78-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=2b694a57-15ad-4a12-bcc0-0ff306893bbf rw quiet
  Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX507ZM_FX507ZM
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FX507ZM v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: FX507ZM.310 date: 01/26/2022
  ID-1: BAT1 charge: 91.1 Wh (100.0%) condition: 91.1/90.2 Wh (100.9%)
    volts: 17.3 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: full
  RAM: total: 15.29 GiB used: 2.47 GiB (16.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x424
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 494 high: 674 min/max: 400/4600:4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 502 2: 543 3: 446 4: 432
    5: 443 6: 461 7: 528 8: 600 9: 544 10: 588 11: 457 12: 428 13: 510 14: 433
    15: 400 16: 400 17: 525 18: 484 19: 674 20: 488 bogomips: 107560
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts cat_l2 cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    f16c flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep serialize sha_ni smap
    smep smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq
    umip vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: ASUSTeK driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
    chip-ID: 10de:2520 class-ID: 0300
  Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-7:3 chip-ID: 322e:202c class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa dri: iris
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x153c built: 2021 res: 1920x1080
    hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel Graphics (ADL GT2)
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel bus-ID: 3-9:4 v: kernel
    alternate: snd_sof_pci_intel_tgl chip-ID: 0b05:6203 bus-ID: 0000:00:1f.3
    class-ID: 0300 chip-ID: 8086:51c8 class-ID: 0403
  Device-2: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228e
    class-ID: 0403
  Device-3: ASUSTek C-Media Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k5.15.78-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Ethernet I219-LM vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 0000:00:1f.6 chip-ID: 8086:1a1e class-ID: 0200
  IF: eno2 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
    chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-cf016a5a-13c1-4a47-8f1c-147832ac2913 maj-min: 254:0
    type: LUKS dm: dm-0 size: 953.57 GiB
  p-1: nvme0n1p2 maj-min: 259:2 size: 953.57 GiB
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 953.87 GiB used: 11.93 GiB (1.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLQ1T0HBLB-00B00
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: FXM7301Q temp: 40.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%) used: 11.93 GiB (1.3%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-cf016a5a-13c1-4a47-8f1c-147832ac2913 label: N/A
    uuid: 2b694a57-15ad-4a12-bcc0-0ff306893bbf
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 472 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: 2FD9-A140
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-2:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-2: 3-7:3 info: Sonix USB2.0 HD UVC WebCam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 322e:202c class-ID: 0e02
  Device-3: 3-9:4 info: ASUSTek C-Media Audio type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 0b05:6203 class-ID: 0300
  Device-4: 3-10:5 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 374 Uptime: 8m wakeups: 441 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: pm: pacman pkgs: 1210 libs: 316 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.23

Hi and welcome to the forum :+1:

That can be caused by not having an accelerated driver installed for your gfx card(s)

Maybe this will help:

1 Like


Most ASUS laptops might need custom kernel boot parameters … See an example here

1 Like

Thank you! I was able to get that ibt=off into the parameters though unfortunately it now appears to be getting stuck on something during boot:
/dev/mapper/luks-7ab4537c-5527-46b9-8f55-52a15a940cfd: clean, 291440/62496768 files, 7309886/249971892 blocks

While something like that line would pop up previously for several seconds during the boot, it would then quickly proceed and boot fully, however I’ve left it at this stage for about 10 minutes or so and it has not progressed. Might I have not added the ibt=off to the correct place in the parameters?

E: Apologies, including where I added ibt=off probably helps. I added it to the end of GRUB_CMDLINE_LINUX_DEFAULT under /etc/default/grub, immediately before the end quote on that line, then used grub-mkconfig -o /boot/grub/grub.cfg and rebooted after that.

EE: I did find Stuck on "... clean, ... files, ... blocks" on laptop screen at boot, however that solution’s not proving to be the most effective, unfortunately… I tried installing the nvidia-beta package from AUR in the hopes that might assist, but that didn’t quite work out either. I tried running nvidia-xconfig in the hopes that generating a basic config would help, but unfortunately that didn’t prove effective either.

Thank you very much!

Okay, I can look into trying to get updated drivers; I have whichever drivers Manjaro’s utility installed by default, I believe it’s video-hybrid-intel-nvidia-prime or something to that effect. And thank you for the link to the Optimus documentation, I appreciate it!

1 Like

Ha! It works!

What I think occurred was a combination of the drivers that TriMoon mentioned, and the ibt=off that bogdancovaciu mentioned.

I would install from a Live USB, install it, and it would be able to boot just fine into what was installed by the Live USB. Afterwards I’d pacman -Syu to update everything, and during one of the installations after running nvidia-settings I’d noticed that the NVIDIA card in my laptop was not recognized any more. I’m not quite sure what fixed that, I believe it was nvidia-xconfig as mentioned under NVIDIA - ArchWiki, however I can’t guarantee that. I also then included the ibt=off kernel parameter, and that allowed me to both reboot, and also actually have a GUI (previously whenever I’d updated after the install and rebooted, I’d not get a GUI/Plasma desktop, and so I thought I had broken something and would reinstall). With those two in place and me getting back to the Plasma desktop, I then turned back towards the drivers, and just now tried to update the kernel from my Live USB’s default of 5.15 to 6.08, and that resolved it. Previously whenever I tried a kernel update it was after a pacman -Syu and the inability to launch a Plasma desktop issue, and I’d re-install again. However after the ibt=off and (somehow) sorting out the graphics card issue revealed by nvidia-settings and being able to reliably get the GUI again, the kernel update then resolved the screen sharing.

Thank you again both to TriMoon and bogdancovaciu, your help is extremely appreciated!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.