Graphic card on PCI slot not appearing when listing

Hello there!

I upgraded the RAM of the PC filling the 4 slots. I installed a clean UEFI Manjaro setup, but I can’t get the graphic card to work.
I listed available PCIs and dont find my card. The BIOS is set to go for the PCI before the IGD and I cannot think of something else.

$ lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation Alder Lake-S GT1 [UHD Graphics 770] (rev 0c)
	DeviceName: Onboard - Video
	Subsystem: Micro-Star International Co., Ltd. [MSI] Alder Lake-S GT1 [UHD Graphics 770]
	Kernel driver in use: i915

The cards is a RX 480 sahppire 8GB that is listed as UEFI supported card. This build (just the RAM change) was working fine a few hours ago in the same Kernel of manjaro.

Any one has any idea of what to check or double check? I don’t know what else to check since I cannot even reach the PCI. Any tip or suggestion would be most welcome.

$ inxi -G
  Device-1: Intel Alder Lake-S GT1 [UHD Graphics 770] driver: i915 v: kernel
  Device-2: Sunplus Innovation HD 720P webcam driver: snd-usb-audio,uvcvideo
    type: USB
  Device-3: AVerMedia Live Gamer Portable 2 Plus
    driver: snd-usb-audio,uvcvideo type: USB
  Display: x11 server: v: driver: X: loaded: modesetting
    dri: iris gpu: i915 resolution: <missing: xdpyinfo/xrandr>
    resolution: 1920x1080
  API: EGL v: 1.5 drivers: iris,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    renderer: Mesa Intel UHD Graphics 770 (ADL-S GT1)

Have you checked it is seated properly? Rechecked?

1 Like

I did. Even unpluged the power of it. The leds go all rainbowy when on.

1 Like

Fair enough. Had to ask.
From a quick search it appears this card is from ~2016, so I dont think its a compatibility or kernel series issue.

1 Like

I don’t think either. I will tear it apart later on and rebuild it, Im going crazy trying to get a clue…

Is the slot used here?

sudo dmidecode -t slot

Does the power supply provide enough power for the GPU? Usually needs external power.

Have you tried to switch slots? The first or the second slot is often the best choice for the primary GPU.

Have you tried resetting the firmware to defaults - save and reboot - usually PEG is chosen when selection is set to auto.

I would like to emphasize the enough power - the leds going rainbowy does indicate the card is getting power - but enough?

How much juice can be delivered from your PSU?

That indicates a power hungry board and CPU - UHD Graphics 770 - you may have been close to the PSU limits with your previous card I reckon.

I went to sleep and when i woke up I disconected everything and clean the PC intensly. I reconnect everything and started working again. I think It might not have been the PCI status, but the PSU as @linux-aarhus said.

I would like to emphasize the enough power - the leds going rainbowy does indicate the card is getting power - but enough?

Since was been powered by 2 diferent cables 1 of those might have come loose at some point and must have not checked good enought.

Thnks all for your time and help

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.