Grand Theft Auto V Issues

#################### inxi -Fxzc0 ########################

System:    Kernel: 5.9.1-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: GNOME 3.36.6 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <filter> 
           UEFI [Legacy]: LENOVO v: EUCN19WW date: 05/12/2020 
Battery:   ID-1: BAT0 charge: 57.9 Wh condition: 57.9/60.0 Wh (96%) model: Celxpert L19C4PC0 
           status: Full 
CPU:       Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP 
           arch: Zen rev: 1 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92666 
           Speed: 1397 MHz min/max: 1400/2900 MHz Core speeds (MHz): 1: 1397 2: 1398 3: 1397 
           4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 10: 1374 11: 1401 12: 1488 13: 1573 
           14: 1644 15: 1399 16: 1397 
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Lenovo driver: nvidia 
           v: 455.28 bus ID: 01:00.0 
           Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 05:00.0 
           Device-3: Chicony Integrated Camera type: USB driver: uvcvideo bus ID: 1-3:2 
           Display: x11 server: 1.20.9 driver: amdgpu,nvidia resolution: <xdpyinfo missing> 
           OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.1-1-MANJARO LLVM 10.0.1) 
           v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo driver: N/A 
           bus ID: 05:00.5 
           Device-2: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 05:00.6 
           Sound Server: ALSA v: k5.9.1-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo 
           driver: r8169 v: kernel port: 2000 bus ID: 03:00.0 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 bus ID: 04:00.0 
           IF: wlp4s0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 251.74 GiB (52.8%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB 
Partition: ID-1: / size: 459.79 GiB used: 249.77 GiB (54.3%) fs: ext4 dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 8.80 GiB used: 1.97 GiB (22.4%) dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 59.5 C mobo: N/A gpu: amdgpu temp: 46 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 386 Uptime: 3h 29m Memory: 7.22 GiB used: 2.10 GiB (29.2%) Init: systemd 
           Compilers: gcc: 10.2.0 Packages: 1347 Client: shell wrapper v: 5.0.18-release 
           inxi: 3.1.05 

I installed Grand Theft Auto V on Steam and ran it with Proton 5.13-1, however I’m only getting around 30fps. After a while of playing the game’s CPU usage goes up to 300% and the game drops to 1fps.

I tried using Proton 5.0-9. On my first attempt it wouldn’t run saying that it couldn’t find the launcher. I reinstalled the game and tried running it on Proton 5.0-9 again but it just wouldn’t open. So far it seems to just work with Proton 5.13-1.

Every graphic settings is in it’s lowest setting or turned off and I’m still getting abysmal performance. Any ideas on how to fix this?

When you switch Proton version back and forth, to avoid issues you could rename or delete the Proton prefix for the specific game found at ~/.local/share/Steam/steamapps/compatdata/{APPID} (note that it will recreate a new prefix from the current Proton version used, so you start fresh but you may lose all configuration and/or savegame in the game, if it is not synced with the Steam Cloud)

Also did you install the hybrid configuration for your GPUs? You have dual GPU so it is not a classic video configuration.

You can try to disable Steam overlay to exclude any possible Proton/Wine issue related to that (the 1FPS you mentioned can be a symptom of an issue in Wine with mouse polling rate).

Thanks for the tip regarding switching between Proton versions.

Yes, I have the latest hybrid drivers installed and run the game with the prime-run %command% launch settings. nvidia-smi shows that the game is using the nVidia GPU.

I’ll try this. Hopefully it helps. Thanks.

Have you tried running with lutris? There’s quite a few customisation options in lutris that may help including feral gamemode. You can also get a log from lutris while the game is running which may help find out what’s going on

No, I haven’t. I’ve tried Lutris with a few other games and they all didn’t work so I got rid of it. Besides, it’s going to take up a lot of space.

GTA5 needs over 80Gib and you’re worried about a few hundred megs with lutris?

You’d be best off using the glorious eggroll proton version the install process is extremely simple.

I tried some time ago to get GTA5 to work. The best way I found was to install a hack to remove the rockstar launcher; even then I got bad frames and my controller didn’t work.

It’s really not worth the hassle imo.

1 Like

Thanks for suggestion but I tried @omano’s tip about switching Proton versions and used the older 4.11 one and the performance has gone way up, albeit with a bit of stuttering.

In theory you should have better performance with current Proton, but if it works for you, good then :wink:
I think you still have an issue though because of what I just said.

Yeah that’s what I was thinking when I first started the game. I’m trying the 5.0 version to see if thats any better.