GPU process crashed running code-insiders

I recently bought Lenovo Yoga 7 Slim Gen 8 and trying to get Manjaro working on it.

I have a strange anomaly right now, that I can’t explain. If I open hardware configuration, it shows that I have an “Unknown Device Name (ATI technologies)”

It’s probably integrated Radeon 780M graphics. So I’ve been going through AMDGPU wiki page – and can’t really understand what the problem is.

If I run inxi -G, I see video card in use with correct amdgpu driver.

Graphics:
  Device-1: AMD Phoenix1 driver: amdgpu v: kernel
  Device-2: IMC Networks Integrated Camera driver: uvcvideo type: USB
  Display: wayland server: X.org v: 1.21.1.12 with: Xwayland v: 23.2.6
    compositor: gnome-shell v: 45.4 driver: gpu: amdgpu
    resolution: no compositor data resolution: 2944x1840
  API: EGL v: 1.5 drivers: radeonsi,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-manjaro1.1
    renderer: AMD Radeon Graphics (radeonsi gfx1103_r1 LLVM 16.0.6 DRM 3.57
    6.8.8-2-MANJARO)

If I run a following command sudo dmesg | grep -i amd. It seems that driver gets properly initialized and used.

[    0.210865] smpboot: CPU0: AMD Ryzen 7 7840S with Radeon 780M Graphics (family: 0x19, model: 0x74, stepping: 0x1)
[    0.211052] Performance Events: Fam17h+ 16-deep LBR, core perfctr, AMD PMU driver.
[    0.806990] pci 0000:00:00.2: AMD-Vi: IOMMU performance counters supported
[    0.809797] AMD-Vi: Extended features (0x246577efa2254afa, 0x0): PPR NX GT [5] IA GA PC GA_vAPIC
[    0.809806] AMD-Vi: Interrupt remapping enabled
[    0.809960] AMD-Vi: Virtual APIC enabled
[    0.810278] perf: AMD IBS detected (0x00000bff)
[    0.810282] perf/amd_iommu: Detected AMD IOMMU #0 (2 banks, 4 counters/bank).
[    2.412815] [drm] amdgpu kernel modesetting enabled.
[    2.416130] amdgpu: Virtual CRAT table created for CPU
[    2.416142] amdgpu: Topology: Add CPU node
[    2.416297] amdgpu 0000:c3:00.0: enabling device (0006 -> 0007)
[    2.513008] amdgpu 0000:c3:00.0: amdgpu: Fetched VBIOS from VFCT
[    2.513013] amdgpu: ATOM BIOS: 113-PHXGENERIC-001
[    2.517939] amdgpu 0000:c3:00.0: [drm:jpeg_v4_0_early_init [amdgpu]] JPEG decode is enabled in VM mode
[    2.551912] amdgpu 0000:c3:00.0: vgaarb: deactivate vga console
[    2.551929] amdgpu 0000:c3:00.0: amdgpu: Trusted Memory Zone (TMZ) feature enabled
[    2.552041] amdgpu 0000:c3:00.0: amdgpu: VRAM: 4096M 0x0000008000000000 - 0x00000080FFFFFFFF (4096M used)
[    2.552049] amdgpu 0000:c3:00.0: amdgpu: GART: 512M 0x00007FFF00000000 - 0x00007FFF1FFFFFFF
[    2.552438] [drm] amdgpu: 4096M of VRAM memory ready
[    2.552441] [drm] amdgpu: 13921M of GTT memory ready.
[    2.553964] amdgpu 0000:c3:00.0: amdgpu: Will use PSP to load VCN firmware
[    3.245827] amdgpu 0000:c3:00.0: amdgpu: RAS: optional ras ta ucode is not available
[    3.254500] amdgpu 0000:c3:00.0: amdgpu: RAP: optional rap ta ucode is not available
[    3.254502] amdgpu 0000:c3:00.0: amdgpu: SECUREDISPLAY: securedisplay ta ucode is not available
[    3.282757] amdgpu 0000:c3:00.0: amdgpu: SMU is initialized successfully!
[    3.367479] amdgpu 0000:c3:00.0: [drm:jpeg_v4_0_hw_init [amdgpu]] JPEG decode initialized successfully.
[    3.405363] amdgpu: HMM registered 4096MB device memory
[    3.407658] kfd kfd: amdgpu: Allocated 3969056 bytes on gart
[    3.407684] kfd kfd: amdgpu: Total number of KFD nodes to be created: 1
[    3.407875] amdgpu: Virtual CRAT table created for GPU
[    3.408703] amdgpu: Topology: Add dGPU node [0x15bf:0x1002]
[    3.408706] kfd kfd: amdgpu: added device 1002:15bf
[    3.408721] amdgpu 0000:c3:00.0: amdgpu: SE 1, SH per SE 2, CU per SH 6, active_cu_number 12
[    3.408729] amdgpu 0000:c3:00.0: amdgpu: ring gfx_0.0.0 uses VM inv eng 0 on hub 0
[    3.408732] amdgpu 0000:c3:00.0: amdgpu: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[    3.408734] amdgpu 0000:c3:00.0: amdgpu: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[    3.408736] amdgpu 0000:c3:00.0: amdgpu: ring comp_1.2.0 uses VM inv eng 6 on hub 0
[    3.408737] amdgpu 0000:c3:00.0: amdgpu: ring comp_1.3.0 uses VM inv eng 7 on hub 0
[    3.408738] amdgpu 0000:c3:00.0: amdgpu: ring comp_1.0.1 uses VM inv eng 8 on hub 0
[    3.408740] amdgpu 0000:c3:00.0: amdgpu: ring comp_1.1.1 uses VM inv eng 9 on hub 0
[    3.408741] amdgpu 0000:c3:00.0: amdgpu: ring comp_1.2.1 uses VM inv eng 10 on hub 0
[    3.408742] amdgpu 0000:c3:00.0: amdgpu: ring comp_1.3.1 uses VM inv eng 11 on hub 0
[    3.408744] amdgpu 0000:c3:00.0: amdgpu: ring sdma0 uses VM inv eng 12 on hub 0
[    3.408745] amdgpu 0000:c3:00.0: amdgpu: ring vcn_unified_0 uses VM inv eng 0 on hub 8
[    3.408746] amdgpu 0000:c3:00.0: amdgpu: ring jpeg_dec uses VM inv eng 1 on hub 8
[    3.408748] amdgpu 0000:c3:00.0: amdgpu: ring mes_kiq_3.1.0 uses VM inv eng 13 on hub 0
[    3.414846] [drm] Initialized amdgpu 3.57.0 20150101 for 0000:c3:00.0 on minor 1
[    3.422896] fbcon: amdgpudrmfb (fb0) is primary device

I’m not sure, what is wong here. The only thing, that doesn’t work is code-insiders pacakge from snap. I’m seeing following issue when I try to run it:

[6521:0511/215245.463385:ERROR:gpu_process_host.cc(993)] GPU process exited unexpectedly: exit_code=133
[6521:0511/215245.463402:WARNING:gpu_process_host.cc(1364)] The GPU process has crashed 5 time(s)
MESA-LOADER: failed to open radeonsi: /snap/core20/current/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib/dri/radeonsi_dri.so) (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
failed to load driver: radeonsi
MESA-LOADER: failed to open kms_swrast: /snap/core20/current/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib/dri/kms_swrast_dri.so) (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
failed to load driver: kms_swrast
MESA-LOADER: failed to open swrast: /snap/core20/current/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib/dri/swrast_dri.so) (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
failed to load swrast driver

I’m not sure, why is driver not being detected as expected?

I’m not sure why that’s happening, however it’s not related.

Right, so there’s nothing wrong with the driver.

I’ve edited your topic title and moved your post to the proper category.

1 Like

If you run a more full inxi like

inxi -Farz

Then maybe we could see more, such as your BIOS version and memory and swap etc.

Here is an output.

System:
  Kernel: 6.8.8-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.8-x86_64
    root=UUID=f8f6ef62-a557-4552-851d-a3a148d54cd2 rw quiet splash apparmor=1
    security=apparmor resume=UUID=99d8a446-902b-40a9-84e0-6c376afbc887
    udev.log_priority=3
  Desktop: GNOME v: 45.4 tk: GTK v: 3.24.41 wm: gnome-shell with: albert
    tools: gsd-screensaver-proxy dm: GDM v: 45.0.1 Distro: Manjaro
    base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 83AA v: Yoga Slim 7 14APU8
    serial: <superuser required> Chassis: type: 10 v: Yoga Slim 7 14APU8
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    part-nu: LENOVO_MT_83AA_BU_idea_FM_Yoga Slim 7 14APU8
    uuid: <superuser required> UEFI: LENOVO v: M6CN38WW date: 11/16/2023
Battery:
  ID-1: BAT0 charge: 36.0 Wh (51.4%) condition: 70.0/70.0 Wh (100.0%)
    power: 8.6 W volts: 15.5 min: 15.5 model: Celxpert L22C4PF7 type: Li-poly
    serial: <filter> status: discharging cycles: 3
CPU:
  Info: model: AMD Ryzen 7 7840S with Radeon 780M Graphics bits: 64
    type: MT MCP arch: Zen 4 gen: 5 level: v4 note: check built: 2022+
    process: TSMC n5 (5nm) family: 0x19 (25) model-id: 0x74 (116) stepping: 1
    microcode: 0xA704101
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 652 high: 1454
    min/max: 400/5132:5289:5447:6076:5605:5760:5918 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 1397
    4: 400 5: 400 6: 400 7: 400 8: 1397 9: 400 10: 1385 11: 400 12: 1454
    13: 400 14: 400 15: 400 16: 400 bogomips: 105442
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS; IBPB:
    conditional; STIBP: always-on; RSB filling; PBRSB-eIBRS: Not affected;
    BHI: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Phoenix1 vendor: Lenovo driver: amdgpu v: kernel arch: RDNA-3
    code: Phoenix process: TSMC n4 (4nm) built: 2023+ pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1, DP-2, DP-3,
    DP-4, DP-5, DP-6, DP-7, Writeback-1 bus-ID: c3:00.0 chip-ID: 1002:15bf
    class-ID: 0300 temp: 29.0 C
  Device-2: IMC Networks Integrated Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2 chip-ID: 13d3:5293
    class-ID: fe01 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.12 with: Xwayland v: 23.2.6
    compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: Samsung 0x4189 built: 2022 res: 2944x1840 dpi: 240
    gamma: 1.2 size: 312x195mm (12.28x7.68") diag: 368mm (14.5") ratio: 16:10
    modes: max: 2944x1840 min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    gfx1103_r1 LLVM 16.0.6 DRM 3.57 6.8.8-2-MANJARO) device-ID: 1002:15bf
    memory: 3.91 GiB unified: no display-ID: :0.0
Audio:
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: c3:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_pci_ps v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
    snd_sof_amd_acp63 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: c3:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: c3:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.8.8-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    vendor: Lenovo driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 01:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Foxconn / Hon Hai Bluetooth Adapter driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0489:e0d8
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives:
  Local Storage: total: 953.87 GiB used: 121.51 GiB (12.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVL21T0HCLR-00BL2 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: EL1QGXA7 temp: 36.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 923.66 GiB size: 908.09 GiB (98.31%)
    used: 121.51 GiB (13.4%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 7.3 MiB (2.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 29.91 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: amdgpu temp: 31.0 C
  Fan Speeds (rpm): N/A
Repos:
  Packages: 1268 pm: pacman pkgs: 1264 libs: 346 tools: gnome-software,pamac
    pm: flatpak pkgs: 0 pm: snap pkgs: 4
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
    1: https://mirror.erickochen.nl/manjaro/stable/$repo/$arch
    2: http://ftp.snt.utwente.nl/pub/linux/manjaro/stable/$repo/$arch
    3: https://manjaro.mirror.wearetriple.com/stable/$repo/$arch
    4: https://mirror.koddos.net/manjaro/stable/$repo/$arch
    5: https://mirror.bouwhuis.network/manjaro/stable/$repo/$arch
    6: https://ftp.nluug.nl/pub/os/Linux/distr/manjaro/stable/$repo/$arch
    7: https://manjaro.mirrors.lavatech.top/stable/$repo/$arch
Info:
  Memory: total: 28 GiB available: 27.19 GiB used: 4.75 GiB (17.5%)
  Processes: 411 Power: uptime: 37m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 10.86 GiB services: gsd-power, power-profiles-daemon, upowerd
    Init: systemd v: 255 default: graphical tool: systemctl
  Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 running-in: tilix
    inxi: 3.3.34

So thats latest.

Seems more problem of the snap.

I generally would avoid SNAP anyways, but have you tried other sources?

Flatpak for if you want it containerized. The AUR also has it available.

1 Like

Removed all snap* packages and snap support from pamac. Also found code-insiders-bin package in AUR repos and it works as expected!

Thank you for your assistance.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.