GPU Accelerated apps tend to flicker the screen's backlight

Hi everyone!

I have a really weird and specific problem with my current setup. Whenever I look at something that is remotely gpu intesive that is accelerated, the screen’s backlight flickers with the content. I have dynamic luminous control, and other settings like this disabled in the display’s settings, and I did not have this problem under windows at all. The most noticeable culprits are the vlc player and firefox, but whenever I try to record the problem using obs, it’s not visible on the video, so the problem does not lie within the rendering of things. Does anyone have a guess about this problem?

Things I already tried:

  • Adding kernel parameters to disable some driver specific settings that were listed on other forums.
  • Updating/Downgrading kernel or GPU driver.

My monitor: LC-POWER UWQHD-100-C (3440x1440@100)

More info about my setup:

  Kernel: 5.15.81-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=14cbb421-7b08-4634-b59c-58fbe53b3503 rw quiet splash
    udev.log_priority=3 nvidia-drm.modeset=1 i915.enable_psr=0
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: MAG B550 TOMAHAWK (MS-7C91) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.80
    date: 12/16/2021
  Message: No system battery data found. Is one present?
  RAM: total: 31.27 GiB used: 3.43 GiB (11.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 gen: 4
    level: v3 note: check built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 1x32 MiB
  Speed (MHz): avg: 3116 high: 3599 min/max: 2200/4650 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3592 2: 2867
    3: 2872 4: 3599 5: 2879 6: 2881 7: 3598 8: 2879 9: 2880 10: 3595 11: 2880
    12: 2872 bogomips: 88835
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
    v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt
    x2apic xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate] vendor: ASUSTeK
    driver: nvidia v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: none off: DP-2 empty: DP-1,DP-3,HDMI-A-1 bus-ID: 2b:00.0
    chip-ID: 10de:2489 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x342mm (31.57x13.46")
    s-diag: 872mm (34.33")
  Monitor-1: DP-2 note: disabled model: UWQHD-100-C built: 2019
    res: 3440x1440 hz: 100 dpi: 110 gamma: 1.2 size: 795x334mm (31.3x13.15")
    diag: 869mm (34.2") modes: max: 3440x1440 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce RTX 3060
    Ti/PCIe/SSE2 direct render: Yes
  Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 1-2.3:4 pcie: chip-ID: 0b05:189c
    class-ID: 0300 gen: 4 serial: <filter> speed: 16 GT/s lanes: 16
    bus-ID: 2b:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2d:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: ASUSTek ASUS TUF H5 Headset type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k5.15.81-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.61 running: yes
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl
    v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 08:00.0
    chip-ID: 14e4:43a0 class-ID: 0280
  IF: wlp8s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp9s0 state: down mac: <filter>
  Device-3: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 2a:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp42s0 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 4.09 TiB used: 434.5 GiB (10.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: S5Z42105 temp: 30.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST4000DM004-2CV104
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5425 serial: <filter> rev: 0001 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 465.66 GiB size: 457.29 GiB (98.20%)
    used: 226.2 GiB (49.5%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:2
    label: N/A uuid: 14cbb421-7b08-4634-b59c-58fbe53b3503
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 27.6 MiB (28.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: E26F-8718
  ID-3: /run/media/konrad/Data raw-size: 3.64 TiB size: 3.58 TiB (98.40%)
    used: 208.27 GiB (5.7%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: Data
    uuid: 8b981649-ca87-5442-bb81-941a7b1bbe87
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 1-2.3:4 info: ASUSTek ASUS TUF H5 Headset type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 0b05:189c class-ID: 0300
    serial: <filter>
  Device-2: 1-5:3 info: Corsair HARPOON RGB PRO Gaming Mouse type: Mouse,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 300mA
    chip-ID: 1b1c:1b75 class-ID: 0300 serial: <filter>
  Device-3: 1-6:5 info: BY Tech Usb Gaming Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 500mA
    chip-ID: 258a:0016 class-ID: 0300
  Device-4: 1-8:6 info: Micro Star MYSTIC LIGHT type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s power: 500mA
    chip-ID: 1462:7c91 class-ID: 0300 serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-5: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 34.0 C mobo: 34.0 C gpu: nvidia temp: 43 C
  Fan Speeds (RPM): cpu: 2033 mobo: 296 gpu: nvidia fan: 0%
  Power: 12v: 12.14 5v: 5.04 3.3v: 3.34 vbat: 1.83
  Processes: 276 Uptime: 3h 55m wakeups: 0 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: 1453 pm: pacman pkgs: 1445 libs: 391 tools: pamac,yay pm: flatpak
  pkgs: 8 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.23
> mhwd -li
Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI
   network-broadcom-wl            2018.10.07               false            PCI

Warning: No installed USB configs!

> mhwd -l
0000:09:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

0000:08:00.0 (0200:14e4:43a0) Network controller Broadcom:
                  NAME               VERSION          FREEDRIVER           TYPE
   network-broadcom-wl            2018.10.07               false            PCI

0000:2b:00.0 (0300:10de:2489) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Did this start recently after an update? Has it always been like this from when you first started using Manjaro with your Nvidia card?

Is the flickering like a “strobe light” or is it slower?

Does it only happen in fullscreen, or even with windowed applications that use GPU acceleration?

Does it also happen with mpv (default settings)?

What happens if you try with VLC, but disable hardware acceleration in its preferences?

What parameters? Did you reset back to defaults now?

This has always been happening since I’ve been using manjaro on this pc, I just didn’t think much about it. But it became very annoying while gaming/watching videos.

It’s speed is totally dependent on the content on the screen. If I stop at the right moment I can control the flicker by highlighting a UI element for example.

Both fullscreen and windowed applications.

I did not use mpv up until this point, but now I tried it. I can sometimes recreate the brightness change by some parts of a video, but it’s not nearly as frequent as in VLC.

I tried the same video that I previously tested it with, but now without acceleration, and got the same results. It seems like that hardware acceleration does not affect it.

nvidia-drm.modeset=1 i915.enable_psr=0 i915.enable_dpcd_backlight=0

I tried them separately and also together, did not change a thing so I removed them.

i915 is for the Intel GPU, but that’s besides the point.

As a shot in the dark, try enabling full composition pipeline in the Nvidia drivers.

Run nvidia-settings as root:

sudo nvidia-settings

Go to X Server Display Configuration → click Advanced at the bottom of the page → check the box for Force Full Composition Pipeline

Click Apply

Now click Save to X Configuration File and save it under /etc/X11/mhwd.d/nvidia.conf

Quit and reboot.


Make sure Sync to VBlank, Allow Flipping, and Use Conformant Texture Clamping are all enabled under OpenGL Settings when you launch nvidia-settings as your normal user (without sudo).

1 Like

With these settings applied, the flickering became even more visible, so much so that I was able to film it using my phone (look at the gray sidebars): YouTube link

  • sorry about the shaky hands

I think I found the solution. So changing the display’s settings before did not change the behavior, but now that I applied the settings that you listed, changing the gamma below a certain threshold (seems to be around 2.2 on this screen) does get rid of the flicker. Thank you very much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.