GPGME errors when using pacman

Hello, I have been unable to update or install any program for some time. When I try to search for updates it gives me this.

sudo pacman -Sy
[sudo] Password for gabriel : 
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Packet database synchronization...
 core 150,4 KiB 1671 KiB/s 00:00 [----------------------------------------------------------] 100%
 extra 8.7 MiB 9.52 MiB/s 00:01 [----------------------------------------------------------] 100%
 multilib 143.9 KiB 1345 KiB/s 00:00 [----------------------------------------------------------] 100%
error : GPGME error : No data
error: error GPGME: No data
error: GPGME error: no data
error: synchronization of all databases failed (invalid or corrupt database (PGP signature))

I’ve tried refreshing the gpg keys with sudo pacman-key --refresh-keys 2> ~/pacman-key-errors.log but the problem persists. The operation generated a lot of errors, which I’m attaching as a log file.

I saw that there was a topic in which someone had exactly the same problem as me. I applied the proposed solution but still no difference.

… doesn’t search for updates

pacman -Syu does

Did you try to refresh your list of mirrors
before you try to update the system?

Your solution solved my problem of updating installations via pacman. But I still can’t update programs installed via AUR repositories.

sudo pamac update

Warning: Building packages as a dynamic user
Warning: Setting the build folder in /var/cache/pamac
Synchronizing package databases...
Checking ckbcomp dependencies...
Check krunner5 dependencies...
Checking pamac-tray-icon-plasma dependencies...
Checking v86d dependencies...
Checking snapd dependencies...
Checking zsh-theme-powerlevel10k dependencies...
Error: Transaction preparation failed: invalid or corrupted database

Edit build files: [e] 
Apply transaction ? [e/y/N] y

Transaction cancelled.

Do not ever use sudo with pamaconly with pacman.

Simple solution.

Update using pacman:

sudo pacman -Syu

Update using pamac:

pamac update

With pamac, if elevated privileges are ever needed, it will ask you.

Using --force-refresh with the pamac command might help to overcome this issue:

pamac update --force-refresh

I hope this helps.


Aside:- Here’s a nice long command for updating your Manjaro system; it chooses the fastest pacman mirrors; performs an update using pacman; performs an update using pamac while forcing a refresh. Copy it to your notes:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syu && pamac update --force-refresh

Thank you very much. With the --force-refresh option, everything is back to normal. As for the use of administrator privileges with pamac, I take note. As for the mirrors, I’ve already been able to define the fastest one before, so there’s no need to do so.

And when that mirror fails, for whatever reason, now you have an alternative method. Thanks for marking my post as the solution, however, I’ve reassigned it to the previous post from @Aragorn - which really solved your issue. All that my post added was a simple command you had probably forgotten.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.