GPGME error: No data & failed to synchronize all databases (invalid or corrupted database (PGP signature))


I’m on KDE Plasma, stable branch.
I’ve come across with the error reported in the title after my last update of Manjaro. When I run sudo pacman -Syyu, I get the following:

error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronising package databases...
core                                  170,9 KiB  99,0 KiB/s 00:02 [------------------------------------] 100%
extra                                1900,3 KiB  2,17 MiB/s 00:01 [------------------------------------] 100%
community                               6,8 MiB  4,65 MiB/s 00:01 [------------------------------------] 100%
multilib                              175,2 KiB   350 KiB/s 00:01 [------------------------------------] 100%
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: failed to synchronize all databases (invalid or corrupted database (PGP signature))

I’ve tried all solutions proposed in the forum plus a few more I found in the Internet, all without avail. Those include updating the mirrors, repopulating keys, checking “pacman.conf”… In particular, I tried the long solution proposed here.
Nothing works, that is, I keep receiving those error messages every time I run pacman or paru. :sweat:

How can I solve the problem?

Here is the output of inxi -Fazy:

Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64
root=UUID=7237cc4d-9ab7-410c-90c4-b8c90e2b10df rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: N/A wm: kwin_x11 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: LENOVO product: 4180Q3U v: ThinkPad T420
serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: LENOVO model: 4180Q3U serial: <filter> UEFI-[Legacy]: LENOVO
v: 83ET82WW (1.52 ) date: 06/04/2018
ID-1: BAT0 charge: 23.1 Wh (98.3%) condition: 23.5/56.2 Wh (41.9%)
volts: 12.4 min: 10.8 model: SANYO 45N1001 type: Li-ion serial: <filter>
status: Unknown
Info: Dual Core model: Intel Core i7-2640M bits: 64 type: MT MCP
arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F
cache: L2: 4 MiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 22338
Speed: 3046 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 3046 2: 3046
3: 3046 4: 3046
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Lenovo ThinkPad T420 driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:0126 class-ID: 0300
Device-2: Chicony integrated camera type: USB driver: uvcvideo
bus-ID: 1-1.6:6 chip-ID: 04f2:b221 class-ID: 0e02
Display: server: X.Org 1.20.13 compositor: kwin_x11 driver:
loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x2100 s-dpi: 96 s-size: 507x554mm (20.0x21.8")
s-diag: 751mm (29.6")
Monitor-1: LVDS-1 res: 1600x900 hz: 60 dpi: 131 size: 310x174mm (12.2x6.9")
diag: 355mm (14")
Monitor-2: DP-3 res: 1920x1200 hz: 60 dpi: 94 size: 518x324mm (20.4x12.8")
diag: 611mm (24.1")
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
v: 3.3 Mesa 21.2.3 compat-v: 3.0 direct render: Yes
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.38 running: yes
Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520
driver: e1000e v: kernel port: 5080 bus-ID: 00:19.0 chip-ID: 8086:1502
class-ID: 0200
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
v: kernel bus-ID: 03:00.0 chip-ID: 8086:0085 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: wwp0s29u1u4i6 state: down mac: <filter>
Device-1: Broadcom BCM2045B (BDC-2.1) type: USB driver: btusb v: 0.8
bus-ID: 1-1.4:4 chip-ID: 0a5c:217f class-ID: fe01 serial: <filter>
Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
Local Storage: total: 3.55 TiB used: 1.54 TiB (43.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3B6Q scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS541010A9E680
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: A7G0 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
model: WD My Book 1130 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 1008 scheme: MBR
ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Samsung model: HD400LD
size: 372.61 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 0000 scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
ID-1: / raw-size: 65.37 GiB size: 63.84 GiB (97.67%) used: 34.29 GiB (53.7%)
fs: ext4 dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 400.39 GiB size: 393.11 GiB (98.18%)
used: 304.77 GiB (77.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
Alert: No swap data was found.
System Temperatures: cpu: 96.0 C mobo: N/A
Fan Speeds (RPM): cpu: 4539
Processes: 353 Uptime: 11h 2m wakeups: 1 Memory: 15.52 GiB
used: 7.65 GiB (49.3%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 12.0.1 Packages: 2100 pacman: 2092 lib: 440 flatpak: 0
snap: 8 Shell: Zsh v: 5.8 running-in: yakuake inxi: 3.3.07

Try this


Thanks for the reply, @bogdancovaciu.
There was progress! I didn’t get the nasty error messages and pacman updated a couple of packages.
However, a notification from Package Manager appeared with nine updates available. Issuing a paru or a pacaur -Syyu didn’t update anything, i.e., I got a message saying “there is nothing to do”.
So, I opened the Add/Remove Software app, and tried to update those packages from there. I got the following error message:

Apparently, I’m on the right track. What’s the best to do from here?

That looks to me as an outdated mirror, but most likely following @linux-aarhus root tip would set things up and solve the issue.


You’re right, @linux-aarhus root tip did solve the problem!
Thank you both for your help. :+1: :clap:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.