Gpg: keyserver receive failed: No data


Yesterday I tried to install the AUR package mullvad-browser-bin. However, it fails, due to a missing public pgp key.

==> Verifying source file signatures with gpg...
    mullvad-browser-linux64-12.0.7_ALL.tar.xz ... FAILED (unknown public key E53D989A9E2D47BF)
==> ERROR: One or more PGP signatures could not be verified!

When I try to add the key in the terminal, I get this failure :

gpg --recv-keys E53D989A9E2D47BF                                                                                                                                 ✔ 
gpg: keyserver receive failed: No data

What am I doing wrong?


gpg --recv-key E53D989A9E2D47BF

You may succeed in retrieving the key by specifying a keyserver

gpg --keyserver hkps:// --recv-keys E53D989A9E2D47BF
1 Like

Thank you @linux-aarhus, the key was imported.

gpg --keyserver hkps:// --recv-keys E53D989A9E2D47BF                                                                                             ✔ 
gpg: key 4E2C6E8793298290: public key "Tor Browser Developers (signing key) <>" imported
gpg: Total number processed: 1
gpg:               imported: 1

How did you know which key server to specify? How should I have searched for it?

I didn’t - I have a list of well known key servers in case I run into the issue myself.


Is there a page or another resource that reference those key servers?

A couple a years back there was attempts to poison the key system.

Almost everything went black and retrieving a key was a hit and miss.

There was a few servers which worked - I keep then in my gpg.conf

keyserver hkps://
keyserver hkp://
keyserver hkps://
keyserver hkps://

Thank you for sharing. It’s good to have something listed in the forum, it could come handy for another poor lost soul like myself :smiley:

I think the topic has been up and around several times - did you search the forum? Of course if you didn’t know about keyserver - then the keyword is not obviouis :slight_smile:

It could be one of the old forum - my gpg.conf has a comment - I think it is around the tihe time of the poison attempts.

###+++--- GPGConf ---+++### tor 27 jun 2019 14:09:36 CEST
# GPGConf edited this configuration file.
# It will disable options before this marked block, but it will
# never change anything below these lines.

I searched, but not with those exact keywords, and anyway I wasn’t sure what to consider ; I didn’t see the same error (“No data”) in the results and I didn’t know how it worked, if there was a logic to understand what key server to try, and I had even more general doubts.

It is not obvious what to look for - I remember I spent quite some time to locate working key servers - I like your desire to understand the background :+1: it is admirable - many just come for the easy solution.

FYI, that one is loooong dead. GnuPG uses hkps:// now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.