Gpg keys cannot be downloaded - no dirmngr

I try to update packages from the AUR using yay. I run yay -Syyu, it lists a bunch of software that needs to be updated, for some it says:

==> ERROR: One or more PGP-signatures couldn't be verified!

At the end of the process, I get this:

:: PGP-keys must be imported: 
 -> 13975A70E63C361C73AE69EF6EEB81F8981C74C7, needed by: gcc10  gcc8  gcc11  gcc9
 -> CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7, needed by: kipi-plugins  libkipi
 -> D81C0CB38EB725EF6691C385BB463350D6EF31EF, needed by: kipi-plugins  libkipi
 -> D8272EF51DA223E4D05B466989AB63D48277377A, needed by: imagemagick6
 -> CB9387521E1EE0127DA804843FDBB55084CC5D84, needed by: phonon-qt4
 -> F3691687D867B81B51CE07D9BBE43771487328A9, needed by: gcc10  gcc11  gcc9
 -> 86CFFCA918CF3AF47147588051E8B148A9999C34, needed by: gcc10  gcc11  gcc9
 -> D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62, needed by: gcc10  gcc8  gcc11  gcc9
 -> F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87, needed by: kipi-plugins  libkipi
:: Import? [Y/n] 
:: Import keys with gpg...
gpg: connecting dirmngr at '/run/user/1000/gnupg/S.dirmngr' failed: IPC "connect" call failed
gpg: Reception from keysercer failed: No Dirmngr
 -> problem while importing keys

I have no idea why eg gcc8, gcc9, gcc10 and gcc11 appear there. I actually removed them running yay -R gccxx (xx= the number), and it reported a successful removal, but when I run yay -Syyu again, I get them in the list again. kipi-plugins is required by digikam, which is installed.
I ran through a number of steps (sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring, sudo pacman-key --init, sudo pacman-key --populate archlinux manjaro), provided by others who had trouble with gpg, but I guess this is simply a problem of outdated keys. Question is, why such packages are being updated without updating the key…
Maybe I am on a completely wrong track. I tried to install the keys individually with

gpg --search-keys --keyserver hkp:// D07BD8662C56CB291B316EB2F5675605C74E02CF

(the key is only an example), it didn’t work. I get always the same error message about dirmngr.

I wonder why you need that as was never updated past 2020 …

That doesn’t exist anymore, not even in AUR.
To me it looks like the system was a bit left on aging, without updates, and i’m sure you also using some outdated mirrors. Please do some cleanup, remove the obsolete packages.
As for the libkipi and kipi-plugins both got flagged out of date, please see the comments on AUR (en) - libkipi and on AUR (en) - kipi-plugins

Remove them via pamac and reboot the system, then run:
sudo pacman-mirrors -f5 && pamac update

The pkgbase is imagemagick6 and the package is actually libmagick6.

Thanks for your input! I work through it. phonon-qt4 is required by kdelibs … I removed it, since it seems not necessary. I work on the other packages and let you know. The system was updated or rather upgraded regularly (it’s not my PC), but in this process you aren’t told that a package is outdated or discontinued, or the message runs by so quickly that it’s impossible to read them. :slight_smile:

That is true. Most of those changes are mentioned in the update announcement like [Stable Update] 2023-05-07 - Kernels, KDE Gear 23.04.0, KDE Frameworks 5.105.0, Qt5, Firefox, Thunderbird - #2 by philm

But if you missed some of those in the past, then yes, you have to go trough … For example, right now on my unstable branch install i have this gem that i have to manually remove. As you can see is nor in our repository nor AUR … and i don’t actually need it.