Gpg fail while dropbox install

Hi everybody!

I looked to pinned post and it’s awesome but not work for me ;(

I try to install dropbox by yay, console say:

:: PGP keys need importing:
 -> 1C61A2656FB57B7E4DE0F4C1FC918B335044912E, required by: dropbox
==> Import? [Y/n] 
:: Importing keys with gpg...
gpg: keyserver receive failed: General error
problem importing keys

By useful tips on pinned post I was looking for 1C61A2656FB57B7E4DE0F4C1FC918B335044912E and I found it inside I opened this page and paste this string, after that got information that it was found!
After that I use this command:

gpg --keyserver --recv-key 1C61A2656FB57B7E4DE0F4C1FC918B335044912E

and console said:

gpg: key FC918B335044912E: no user ID
gpg: Total number processed: 1

processed I expected that yay -s dropbox will give me successful installation, but give me same error like before

PS. I am newbie and tried from few Hs resolved with google and my very limited knowledge about linux, so if solution is simple, I’m sorry!

Have a nice day :slight_smile:

Download the public key from

Go to the folder where you downloaded the key and use the following command:

gpg --import rpm-public-key.asc

1 Like

Hello :slightly_smiling_face:!
As @chomsky mentioned, you can always download the public key directly.
Alternatively, you can try a different keyserver:

gpg --keyserver hkp:// --recv-keys 1C61A2656FB57B7E4DE0F4C1FC918B335044912E
1 Like

I’m confused…
Where keys should be located? Where I want to be? I was thinking about /etc/pacman.d/gnupg
Where you suggest to do this command?

Clicking the link wil let you download the key, select your donwload folder. Open a terminal and cd to your downloads folder then type gpg --import rpm-public-key.asc

Or do what @DarkWav mentioned.

1 Like

You right ofc!

Thanks a lot, it works.

Actually I do not understand why it did not before ;/ Anyway thank you a lot <3

The only thing I changed was the keyserver, seems like hkp:// is more reliable than I’m glad it worked for you!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.