Got error while opening root access in terminal

I want to get access to the root permission
I tried this command named as sudo su in the terminal
it asked for my password
i submitted correct password
after submitting the password I get this error

su: failed to execute /bin: Permission denied

please guide me to the solution

1 Like

I’m not too sure exactly what you’re trying to do. If you want to switch to the the root user, it is simply: su

Or you can run individual commands as root using sudo <command>


sudo -s

But that’ll only work if your user is already in the wheel group.


For the future, please read this:


Hi @ayush222006,

Almost sounds, to me, like you provided the root password on that request. I don’t know why this is so, but it was very confusing for me too, until only recently. This is how I understand it:

When you wish to run a command as as your own user but with root priviledges, you run it with sudo. For example:

sudo ls /

(Yeah, I know it’s basic, but that’s not the point.)

When you run that command as your user, not root, it’ll still execute as YOU, and not as root, but it will give you the same results as if you ran:

ls /

as the root user.

Hence, yo use sudo you need to use your own user’s password, not root’s. So,

sudo su

requires you to use your own password.

However, that’s unnecessary. (Yeah, I also only learnt this recently.) I you require a root shell, it’s only necessary to run su:


For that you have to enter root’s password, not your user’s. You are then root, and all commands are executed as root with root priviledges and permisssions.

Read more here.

Hope this helps!

1 Like

Just as an aside, never use su just like that unless you really know what you’re doing.

Always use… :arrow_down:

su -

… or… :arrow_down:

su -l root

… or… :arrow_down:

su - root

Rationale: If you use su without the dash, then you will be running a root shell but with the environment of the invoking user. This means that you may accidentally overwrite files in your home directory and cause them to become root-owned.


thanks very very much
the command you provided worked with ease
:grinning: :grinning: :grinning: :grinning: :grinning:

1 Like

Just saw this now. Thank you! Now I know and will work accordingly!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.