Got a lot of questions about screens, Nvidia and Xrandr

Hello everyone!

I am currently running Manjaro 21.0 with Nvidia Drivers 460.56, NV-Control 1.29 and Nvidia Server 11.0. Totally newbie with Manjaro and got back in the Linux world after something like 9 years.

I am pretty sure I’ve installed Manjaro with proprietary drivers and my GPU is a GT 710.

I am quite a lot confused regarding the graphic card configuration so I’ll explain all the things I’m still struggling with.

Starting off with Nvidia Server. My setup features 2 different displays, one is a 4:3 and another is a 16:9 which requires some extra configuration because the overscan has to be set. I’ve managed to tweak the nvidia server based on my likings and saved the X configuration file to /etc/X11/xorg.conf.d/20-nvidia.conf but somehow this configuration is not loaded correctly at start.

The main issue is that if the viewportin has a vertical resolution equal to the “panning” then the panel is not shown. Giving just one more pixel to panning will make the panel appear and I have to tweak the panning each and every time at start. Somehow the viewportin and viewportout are loaded correctly at start, but I still have to tweak this little tweak every time (looking at the configuration it’s setup correctly). What can I check in order to prevent this behaviour? Is there any configuration that is maybe overriding the one I’ve created?

Second question regards the refresh rate. When I didn’t have Manjaro, I’ve used to tweak the clock of my primary monitor up to 75hz and it run just smooth. It’s rated at 60hz maximum. Now, I understand the risk of doing this operation, but somehow I just can’t find out how I can achieve it. There’s this xrandr CLI, but I can’t make it work. Can’t I just force a resolution via nvidia-server?

Another bummer that is compromising my experience is when my primary monitor (the one with overscan and custom resolution) is powered off or when I log back in without powering it on. Basically, when this happens, the nvidia configuration gets lost and the screen are mirrored and the primary display is in a weird resolution, so I’ll have to re-configure nvidia-settings from scratch. Is there a way I can force the configuration to be reloaded when a monitor is detected? Or at least at every login?

And finally another question about xrandr. I’ve found this neat command that will dim the screen and I want to make a script out of it so that when I hit a combination with my keyboard it dims the screen.

xrandr --output DVI-D-0 --brightness X.X && xrandr --output VGA-0 --brightness X.X

The problem is that whenever I give this command the nvidia settings get overriden so again I’ll have to reconfigure everything. Is there a way I can give this command without making the configuration once again?

Hi @iamgabrieler ,
Please, search in the forum the above quoted words in order to find an answer for your questions.

Hope this help, regards.

1 Like

Hi @j8a , thanks for this, but I still need help. I’ve read a lot of many different posts but all the descripted problems are still affecting me.

Hi @iamgabrieler ,
I could help you whether you post the output of the following terminal command in this thread:
inxi -Fazy

I need the output to see the kernel settings and the video card you have, in order to suggest a post that suits your needs.

BTW, you can read the following post:
Nvidia X Server not saving settings
or perhaps, the last one I found:
My resolution is not available in resolution list


Hi @j8a

Output of inxi -Fazy gives this:

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=6f631138-7938-4581-970d-fd032ed41dff ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Hewlett-Packard product: HP Compaq dc5850 Microtower 
  v: N/A serial: <filter> Chassis: type: 6 serial: <filter> 
  Mobo: Hewlett-Packard model: 3029h serial: <filter> BIOS: Hewlett-Packard 
  v: 786F6 v01.09 date: 04/09/2008 
  Info: Quad Core model: AMD Phenom 9750B bits: 64 type: MCP arch: K10 
  family: 10 (16) model-id: 2 stepping: 3 microcode: 1000083 cache: L2: 2 MiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 19163 
  Speed: 2400 MHz min/max: 1200/2400 MHz Core speeds (MHz): 1: 1200 2: 1200 
  3: 1200 4: 1200 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI 
  driver: nvidia v: 460.67 alternate: nouveau,nvidia_drm bus-ID: 02:00.0 
  chip-ID: 10de:128b class-ID: 0300 
  Device-2: AVerMedia AVerTV DVB-T (A867) type: USB driver: dvb_usb_af9035 
  bus-ID: 1-6:5 chip-ID: 07ca:a867 class-ID: 0000 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia display-ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 3291x1134 s-dpi: 95 s-size: 879x300mm (34.6x11.8") 
  s-diag: 929mm (36.6") 
  Monitor-1: VGA-0 res: 1280x1024 dpi: 96 size: 340x270mm (13.4x10.6") 
  diag: 434mm (17.1") 
  Monitor-2: DVI-D-0 res: 2011x1133 hz: 60 dpi: 73 
  size: 700x390mm (27.6x15.4") diag: 801mm (31.5") 
  OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67 
  direct render: Yes 
  Device-1: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 02:00.1 chip-ID: 10de:0e0f 
  class-ID: 0403 
  Device-2: C-Media Audio Adapter (Unitek Y-247A) type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 9-1:2 chip-ID: 0d8c:0014 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.24 running: no 
  Device-1: Broadcom NetXtreme BCM5754 Gigabit Ethernet PCI Express 
  vendor: Hewlett-Packard driver: tg3 v: kernel port: 1120 bus-ID: 3f:00.0 
  chip-ID: 14e4:167a class-ID: 0200 
  IF: enp63s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter> 
  IF-ID-2: veth3b6ae21 state: up speed: 10000 Mbps duplex: full mac: <filter> 
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB 
  driver: btusb v: 0.8 bus-ID: 6-3:4 chip-ID: 0a12:0001 class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Local Storage: total: 838.38 GiB used: 53.23 GiB (6.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G 
  size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: SSD serial: <filter> rev: B1D1 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500DM002-1BD142 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: KC48 scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST3160815AS 
  size: 149.05 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: H scheme: MBR 
  ID-1: / raw-size: 76.5 GiB size: 75.25 GiB (98.36%) used: 53.23 GiB (70.7%) 
  fs: ext4 dev: /dev/sda4 maj-min: 8:4 
  Alert: No Swap data was found. 
  Message: No sensors data was found. Is sensors configured? 
  Processes: 256 Uptime: 10m wakeups: 0 Memory: 6.77 GiB 
  used: 1.91 GiB (28.2%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: 1468 pacman: 1424 lib: 413 flatpak: 18 
  snap: 26 Shell: Bash v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.03 

I’ve read the documentation but still I just don’t get this right. Everytime the first monitor shuts down, the resolution is back to a “default” state. When I log in, sometimes it’s a resolution, sometimes it’s another. I just can’t get it somehow.

Hi @iamgabrieler ,
I am not able to further help you, I just tried to search the forum with the name of your nvidia card NVIDIA GK208B [GeForce GT 710]
and I could only can suggest a last post to read from the Stable Update on December 12th
[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1 - #540 by verminator
In this post @verminator has a similar problem.

BTW, linux59 is EOL and you could install other kernel like linux54 or linux510 in order to try and fix your problem.


If it isn’t clear: the following posts there addressed that problem and I was able to fix it.