Google Drive folder is unreachable in Gnome (Nautilus & Déja-dup)

I notice today that all Gnome programmes seem to have become unable to access my Google Drive, which worked fine until a few days ago. If I try to mount the folder in Nautilus, mounting fails reporting that “Timeout was reached”. Even Déja-dup (which copies the backup to a Google Drive folder) fails to perform the backup giving this error:

Traceback (innermost last):
  File "/usr/bin/duplicity", line 87, in <module>
  File "/usr/bin/duplicity", line 70, in with_tempdir
  File "/usr/lib/python3.10/site-packages/duplicity/", line 1567, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/lib/python3.10/site-packages/duplicity/", line 1244, in ProcessCommandLine
    config.backend = backend.get_backend(args[0])
  File "/usr/lib/python3.10/site-packages/duplicity/", line 223, in get_backend
    obj = get_backend_object(url_string)
  File "/usr/lib/python3.10/site-packages/duplicity/", line 209, in get_backend_object
    return factory(pu)
  File "/usr/lib/python3.10/site-packages/duplicity/backends/", line 117, in __init__
    file_list ={u'q': u"'Root' in parents and trashed=false"}).GetList()
  File "/usr/lib/python3.10/site-packages/pydrive2/", line 163, in GetList
    for x in self:
  File "/usr/lib/python3.10/site-packages/pydrive2/", line 147, in __next__
    result = self._GetList()
  File "/usr/lib/python3.10/site-packages/pydrive2/", line 84, in _decorated
    return decoratee(self, *args, **kwargs)
  File "/usr/lib/python3.10/site-packages/pydrive2/", line 83, in _GetList
  File "/usr/lib/python3.10/site-packages/googleapiclient/", line 130, in positional_wrapper
    return wrapped(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/googleapiclient/", line 923, in execute
    resp, content = _retry_request(
  File "/usr/lib/python3.10/site-packages/googleapiclient/", line 222, in _retry_request
    raise exception
  File "/usr/lib/python3.10/site-packages/googleapiclient/", line 191, in _retry_request
    resp, content = http.request(uri, method, *args, **kwargs)
  File "/usr/lib/python3.10/site-packages/oauth2client/", line 173, in new_request
    resp, content = request(orig_request_method, uri, method, body,
  File "/usr/lib/python3.10/site-packages/oauth2client/", line 280, in request
    return http_callable(uri, method=method, body=body, headers=headers,
  File "/usr/lib/python3.10/site-packages/httplib2/", line 1701, in request
    (response, content) = self._request(
  File "/usr/lib/python3.10/site-packages/httplib2/", line 1421, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/python3.10/site-packages/httplib2/", line 1343, in _conn_request
  File "/usr/lib/python3.10/site-packages/httplib2/", line 1133, in connect
    sock.connect((, self.port))
 TimeoutError: timed out

I have tried to remove the Google account and re-add it but to no avail and I’m really clueless. At the same time, accessing my Google Drive(s) is really crucial for me.

If is an AUR package, then you have to rebuild it …

Is it an AUR package? I don’t think so. It’s the built-in functionality of Nautilus which lets you mount your Google Drive(s) if you have added a Google account in Online accounts. I don’t remember having installed anything from AUR related to this.

For the moment I have solved the problem using Rclone. Mounting the Google drive with the command

rclone mount nameofmygoogledrive: ~/nameofmygoogledrive

works like a charm.

Long live Rclone.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.