Google-chrome-stable and google-chrome-beta distinct behavior for title bar button positions

Hi there!

I am using google-chrome (Stable) and google-chrome-beta at the same time, on the same laptop.

I have configured both of them with a “custom” theme.
However, the title bar buttons are not in the same location.

  • On google-chrome-stable, it follows the OS Settings, which are buttons on the left
  • On google-chrome-beta, it does not.

Any idea why?
Both browsers have the same theme.

Google ChromeVersion 106.0.5249.119 (Official Build) (64-bit)

Google Chrome Beta: Version 107.0.5304.3

Any idea why?
Thans :pray:

Try disabling your GNOME Shell Extensions and see which one is causing it.

Hi @Yochanan ,

Thanks for your message :pray:

I have just tried to disable every extension and it does not change anything :confused:

Should I have closed every google-chrome-beta window and re-open one to validate?
I have just (un-)toogled the extensions and try to open a new window. where others where already opened.

Did you log out / log in after doing so?

Yes.

FYI, I have just applied some updates and rebooted the laptop.

It turns out that now, neither google-chrome nor google-chrome-beta has the window title bar buttons on the left side as configured in Gnome Tweak :disappointed:

After a quick check, google-chrome is now at version Version 107.0.5304.87 (Official Build) (64-bit) and google-chrome-beta is Version 108.0.5359.22 (Official Build) beta (64-bit).

Maybe it is something related to the Chromium >=107?

I think this is it …

https://askubuntu.com/questions/1438090/ubuntu-gnome-chrome-107-breaks-the-position-of-the-close-button-in-classic-th

With upstream bug here: 1370444 - chromium - An open-source project to help move the web forward. - Monorail