"goodram" SD card don't want me to reed it :(

I just bought my 16GB goodram SD for booting raspberry pi on it. It is compatible with win7 and it should run on FAT32 but… I can’t read it on my laptops, current with Manjaro and the second one with win7. I was trying to restart computer, finding it with fdisc etc but with no results. Is it even possible to run it on Manjaro, if it’s not compatible, if not any clues how to get it to working on windows?


p.s it works on my phone

You might need a new SD card reader if your computer can’t read it on either Windows or Manjaro, but works on phone.

Both of those are internal and on Manjaro it’s my first usage of this reader so it should be fine

I have heard of a saying:
It’s new … with
being interpreted as an acronym for
Never Ever Worked

I found it in device Manager on my win7 computer but i can’t do much with it. Any further ideas ?

… because of your pleading emoji …
It most likely IS fine and working - just not properly configured.

But what I said has quite some truth in it - especially when troubleshooting
… don’t just assume it works just because it’s new …

1 Like

Can you format it?

No, it’s showing me capacity but i can’t format it

I hate my life, third adapter worked magically :V

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.