Gnucash report not showing

Hi everybody,
I have have a problem with reports not showing on Gnucash, and it looks like being manjaro KDE specific.
When I say “not showing”, it means the windows stays grayed, it doesn’t generate an empty report as if the accounts were empty or the data range out of scope.
I’ve tested the same gnucash database on the gnucash on linux mint and windows 10 and the reports work as expected.
On manjaro, I tried gnucash v 5.5 (from official repo) and 5.6 (flatpak) and both won’t generate reports.

What could I try ?


If you are willing you change to testing branch and update then you could use from the Manjaro repos version 5.6-2. It could be that Plasma 6 is better compatible with the package and dependencies.

No, I need a stable machine …

Tip: What is currently in the testing branch will be in the stable branch soon :tm:

Please see Manjaro Features

This is one possibility. There is an issue rendering reports in some Linux versions that is about webkitgtk not GnuCash so it’s completely independent of GnuCash version. It has been reported for GnuCash releases as early as 4.4. Also, while there is a known issue with Nvidia drivers (reportedly resolved by Nvidia Linux driver 535.113.01), there are a couple of other ways that packagers can screw up the webkitgtk dependencies and break GPU acceleration regardless of GPU brand.

The workaround is to set an environmental variable that disables compositing in Webkitgtk. You can check to see if this fixes it for you by starting flatpak Gnucash in the terminal using the following command:

WEBKIT_DISABLE_COMPOSITING_MODE=1 flatpak run org.gnucash.GnuCash

If that allows you to see the reports, then setting the environmental variable “WEBKIT_DISABLE_COMPOSITING_MODE=1” will fix it.

that’s it @cem365mj, it works this way, thanks. Added WEBKIT_DISABLE_COMPOSITING_MODE=1 to /etc/gnucash/environment and that’s it.

I still don’t know what’s brocken as it worked on monday, and not on tuesday, but manaro has to keep some mystery ! :wink:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.