Gnucash - latest update - missing


#1

I received a reminder for 1 update today. It was for gnucash 2.6.18-2. When I tried to upgrade it I got:
Synchronizing package databases…
Starting full system upgrade…

Preparing…

Building gnucash…
Cloning into ‘gnucash’…
remote: Counting objects: 40, done.
remote: Compressing objects: 100% (40/40), done.
remote: Total 40 (delta 18), reused 0 (delta 0)
Unpacking objects: 100% (40/40), done.
==> Making package: gnucash 2.6.18-2 (Wed Sep 27 17:49:36 AWST 2017)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Downloading gnucash-2.6.18.tar.bz2…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- 0:00:01 --:–:-- 0
curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading https://github.com/Gnucash/gnucash/releases/download/2.6.18/gnucash-2.6.18.tar.bz2
Aborting…

Looks like the file is missing from the github.com. I wonder why we get an update for it while the file isn’t there to download!


#2

It is always good to look at the comments for AUR Packages. The first one contains a solution for this problem. The maintainer just forget a -1 in the filename.

https://aur.archlinux.org/packages/gnucash/

source=(https://github.com/Gnucash/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-1.tar.bz2)

Notice ...-1.tar.bz2

#3

We don’t maintain the AUR only give you the option to use it, if wanted, however don’t recommend it.


#4

I already have gnucash 2.6.18-1 installed. The update is for gnucash 2.6.18-2. The file is missing from https://github.com/Gnucash/gnucash/releases/download.


#5

You should ask the Gnucash developer then. :slight_smile:


#6

Yes Phil I am aware of this.


#7

If you read the first comment on the aur website, then you will see that the comment is about 2.6.18-2.

Also the change form version 2.6.18-1 to 2.6.18-2, is just the change of the source URL form sf to github.

The -1 hast nothing to do with the aur packages name and version, it is about the own gnucash version number on github.


#8

Don’t ask us. Ask the maintainer of the package yourself

# Maintainer: Jörg Schuck <joerg_schuck AT web DOT de>

#9

Cool thanks.


#10

Nothing has changed for the package, except that he changed it to github sources. No need to recompile the package as of now. It can be simply ignored for the next version.


#11

Yes, I noticed this. I shall wait till the next version. Thank you Phil.


#12

@keybyte - it does not build anyway, it gets its knickers in a twist over webkitgtk, I tried earlier this week.

:Edit: - just tried again:

/usr/lib/libwebkitgtk-1.0.so.0: undefined reference to `cairo_gl_surface_get_width'
/usr/lib/libwebkitgtk-1.0.so.0: undefined reference to `cairo_egl_device_create'
/usr/lib/libwebkitgtk-1.0.so.0: undefined reference to `cairo_glx_device_create'
/usr/lib/libwebkitgtk-1.0.so.0: undefined reference to `cairo_gl_surface_get_height'
/usr/lib/libwebkitgtk-1.0.so.0: undefined reference to `cairo_gl_device_set_thread_aware'
/usr/lib/libwebkitgtk-1.0.so.0: undefined reference to `cairo_gl_surface_create_for_texture'
collect2: error: ld returned 1 exit status
make[4]: *** [Makefile:688: gnucash] Error 1
make[4]: Leaving directory '/home/steve/yaourt/yaourt-tmp-steve/aur-gnucash/src/gnucash-2.6.18/src/bin'
make[3]: *** [Makefile:788: all-recursive] Error 1
make[3]: Leaving directory '/home/steve/yaourt/yaourt-tmp-steve/aur-gnucash/src/gnucash-2.6.18/src/bin'
make[2]: *** [Makefile:565: all-recursive] Error 1
make[2]: Leaving directory '/home/steve/yaourt/yaourt-tmp-steve/aur-gnucash/src/gnucash-2.6.18/src'
make[1]: *** [Makefile:794: all-recursive] Error 1
make[1]: Leaving directory '/home/steve/yaourt/yaourt-tmp-steve/aur-gnucash/src/gnucash-2.6.18'
make: *** [Makefile:647: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build gnucash.
==> Restart building gnucash ? [y/N]
==> --------------------------------

#13

Happened to me too xircon. I shall wait for the next version.


#14

Downgrade cairo or rebuild webkitgtk2


#15

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.