GNOME will not start on boot (fresh Manjaro 20.1 install)

I bought an HP laptop yesterday, here it is: https://support.hp.com/ee-en/document/c06703649
I had windows 10 preinstalled and I wanted to dual boot it with Manjaro GNOME (I need windows for university stuff).
I installed it and the graphical interface wouldnt appear at all, I was stuck with a balck screen, I could go into the text mode with ctrl alt F5 tho. I updated the system, did simple updating stuff thru the terminal. After rebooting that didnt help. On other manjaro groups I found some help and it looks like upon startup the GNOME enviroment cannot load. After running the command:

sudo systemctl restart gdm

GNOME would start and work properly. (as a side note, during installation, booting from live usb, I didnt have ANY issues with the graphical enviroment).
Here is output of journalctl -e -u gdm command:

I have polish datetime, “wrz” is just short for september.

wrz 27 01:30:15 john-hp systemd[1]: gdm.service: Succeeded.
wrz 27 01:30:15 john-hp systemd[1]: Stopped GNOME Display Manager.
-- Reboot --
wrz 27 01:30:29 john-hp systemd[1]: Starting GNOME Display Manager...
wrz 27 01:30:29 john-hp systemd[1]: Started GNOME Display Manager.
wrz 27 01:30:29 john-hp gdm[498]: Child process -680 was already dead.
wrz 27 01:31:41 john-hp systemd[1]: Stopping GNOME Display Manager...
wrz 27 01:31:41 john-hp systemd[1]: gdm.service: Succeeded.
wrz 27 01:31:41 john-hp systemd[1]: Stopped GNOME Display Manager.
-- Reboot --
wrz 27 13:35:48 john-hp systemd[1]: Starting GNOME Display Manager...
wrz 27 13:35:48 john-hp systemd[1]: Started GNOME Display Manager.
wrz 27 13:35:48 john-hp gdm[485]: Child process -599 was already dead.
wrz 27 13:37:31 john-hp systemd[1]: Stopping GNOME Display Manager...
wrz 27 13:37:31 john-hp systemd[1]: gdm.service: Succeeded.
wrz 27 13:37:31 john-hp systemd[1]: Stopped GNOME Display Manager.
wrz 27 13:37:31 john-hp systemd[1]: Starting GNOME Display Manager...
wrz 27 13:37:31 john-hp systemd[1]: Started GNOME Display Manager.
wrz 27 13:37:38 john-hp gdm-password][1489]: gkr-pam: unable to locate daemon control file
wrz 27 13:37:38 john-hp gdm-password][1489]: gkr-pam: stashed password to try later in open session
wrz 27 13:37:38 john-hp gdm-password][1489]: pam_systemd_home(gdm-password:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
wrz 27 13:37:38 john-hp gdm-password][1489]: pam_unix(gdm-password:session): session opened for user john(uid=1000) by (uid=0)
wrz 27 13:37:38 john-hp gdm-password][1489]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring

I tried reinstalling Manjaro GNOME 20.1 3 times, each installation had the same problem. ( I also tried flashing the USB stick a few times by downloading the iso a few times)

Also my inxi:

~ >>> inxi -Fzxxm                                                                                                                                                                                                 
System:    Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 
           Distro: Manjaro Linux 
Machine:   Type: Convertible System: HP product: HP ENVY x360 Convertible 13-ay0xxx v: Type1ProductConfigId serial: <filter> 
           Chassis: type: 31 serial: <filter> 
           Mobo: HP model: 876E v: 12.36 serial: <filter> UEFI: Insyde v: F.12 date: 07/28/2020 
Battery:   ID-1: BAT1 charge: 49.6 Wh condition: 51.4/51.0 Wh (101%) volts: 12.9/11.6 model: Hewlett-Packard PABAS0241231 
           serial: <filter> status: Discharging 
           Device-1: hid-0018:04F3:2AF4.0001-battery model: ELAN2514:00 04F3:2AF4 serial: N/A charge: N/A status: N/A 
Memory:    RAM: total: 15.09 GiB used: 1.68 GiB (11.2%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP arch: Zen rev: 1 
           L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31948 
           Speed: 1397 MHz min/max: 1400/2000 MHz Core speeds (MHz): 1: 1396 2: 1398 3: 1397 4: 1400 5: 1400 6: 1397 7: 1397 
           8: 1397 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 04:00.0 
           chip ID: 1002:1636 
           Display: x11 server: X.org 1.20.8 compositor: gnome-shell driver: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa resolution: <xdpyinfo missing> 
           OpenGL: renderer: AMD RENOIR (DRM 3.38.0 5.8.6-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.7 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 04:00.1 
           chip ID: 1002:1637 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard 
           driver: snd_rn_pci_acp3x v: kernel bus ID: 04:00.5 chip ID: 1022:15e2 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtw_8822ce 
           v: N/A port: 2000 bus ID: 01:00.0 chip ID: 10ec:c822 
           IF: wlo1 state: up mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 7.17 GiB (1.5%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1006 size: 476.94 GiB speed: 15.8 Gb/s 
           lanes: 2 serial: <filter> 
Partition: ID-1: / size: 233.31 GiB used: 7.09 GiB (3.0%) fs: ext4 dev: /dev/nvme0n1p5 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 30.9 C mobo: N/A gpu: amdgpu temp: 30 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 295 Uptime: 26m Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1120 Shell: Zsh v: 5.8 
           running in: gnome-terminal inxi: 3.1.05 
~ >>>                                                                                                                                                                                                             

I woudl really like to run GNOME enviroment on my laptop, please help me fix it.

Im sorry i posted this post previously in a wrong category

  1. export LANG=C
    

    will set the language of your terminal to English until you quit it.

     set LANG=C; command
    

    will execute 1 command with English output

  2. support is built into the kernel so try a few other kernels if your current one is having problems:

    mhwd-kernel --install linux59
    mhwd-kernel --install linux54
    

    would be prime candidates (latest RC and latest LTS respectively)

:innocent:

@John1776 Did you figure out how to fix this so that it boots into the Gnome DE automatically?

I’m having exactly the same issue on my Dell XPS with the latest Manjaro Gnome 20.1.1 Mikah (10-1-2020 release) installed. I have kernel v5.8.11-1 installed.

Try installing and switching to LTS kernel or 5.9 kernel

1 Like

Howdy!
Have you tried to execute sudo systemctl enable gdm , may I ask?

1 Like

And please report back if 5.4 or 5.9 works so we can “solve” this issue as @John1776 never reported back.

@Computer_Email23 I tried both kernel versions and still had the same issue. Doesn’t seem to be related to that.

@The_Quantum_Alpha I also tried that, but no change. Still have the same issue.

That being said, the only OS I have on my system is Manjaro so I never actually go to Grub during the boot process. Does that seem weird or is that normal?

I see :thinking:

Could you please login into the TTY, then execute startx then provide me the output?

There is some output there, but it automatically boots into the Gnome interface before I can even read it, much less copy it. Do you know how I might be able to capture it?

Hm, able to take a picture, may I ask? :upside_down_face:

I was actually able to capture the output to a file with
startx &> output.txt

Here’s the output:



X.Org X Server 1.20.9
X Protocol Version 11, Revision 0
Build Operating System: Linux Manjaro Linux
Current Operating System: Linux nighthawk 5.8.11-1-MANJARO #1 SMP PREEMPT Wed Sep 23 14:35:40 UTC 2020 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=16631120-a90c-4167-9427-233508984006 rw quiet apparmor=1 security=apparmor udev.log_priority=3
Build Date: 02 September 2020  07:39:17AM
 
Current version of pixman: 0.40.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/kylerjohnsondev/.local/share/xorg/Xorg.0.log", Time: Wed Oct 14 17:26:12 2020
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset(G0): Initializing kms color map for depth 24, 8 bpc.

Thank you!
Could you please provide me the file ~/.local/share/xorg/Xorg.0.log please?

There isn’t an xorg folder in the ~/.local/share/ directory

Hm :thinking:

Can you try and run these commands, please?

sudo -i
systemctl stop gdm
systemctl disable graphical.target multi-user.target gdm
pacman -S gnome 
pacman -Rns gnome
pacman -S gnome
systemctl enable gdm graphical.target
reboot

I had the same issue on my new work computer (Thinkpad T14s, AMD R5-4650U Ryzen) a week ago. Since I did not find a solution, I installed Ubuntu. A weird thing is that when I was on that black screen, starting TTY2 and then TTY1 suddenly made the GDM Login Screen appear. I hope there will be a non hacky solution soon, since I want to have Manjaro back on that computer as soon as possible. :confused:

When I install gnome, I get prompts about conflicts:

nautilus and nautilus-typeahead. Wants to remove nautilus.
libnautilus-extension-typeahead and libnautilus-extension. Wants to remove libnautilus-extension.
gnome-software and pamac-gnome-integration. Wants to remove pamac-gnome-integration.

It wouldn’t let me reinstall gnome unless I allow it to remove those three packages, so that’s what I did.

After the reboot, I still have the same problem, though.

Seems GDM is the issue here. Why not try with lightdm? Simply do following cmds:

sudo systemctl disable gdm
pamac install lightdm-gtk-greeter
sudo systemctl enable lightdm

@philm Thanks for the response! After switching to lightdm, it boots right into a login screen as expected and I can login to the Gnome desktop.

– BUT –

The login screen it renders is so ugly and difficult to read (super small) that it’s almost worth sticking with GDM and just logging into TTY to run startx to boot the desktop :rofl:

This does establish that GDM or the GDM configuration is the problem, though. I wonder if there is anyway to get GDM working on my machine. It seems possible since it works perfectly after logging into TTY and restarting it.

@philm If I run systemctl status gdm.service, I see that it’s active (running) and enabled.

I do see an error, though.

gdm[712]: GdmDisplay: Session never registered, failing.
gdm[712]: Child process -853 was already dead.
gdm[712]: Child process -853 was already dead.
gdm[712]: Child process -909 was already dead.

Does that mean anything to anyone?

For me, it turned out to be a driver issue. I have an Nvidia GPU as well as the Mesa Intel UHD onboard graphics.

I installed the hybrid driver with

sudo mhwd --install pci  video-hybrid-intel-nvidia-440xx-prime

Then, I updated grub so the changes would take effect:

sudo update-grub

I’ve rebooted several times now and the GDM login screen comes up automatically for me.