Gnome Web quitting immediately after launch

Been trying to track down this issue for a while with no luck, so I thought I’d post here. Issue started after I installed the Epiphany Dev flatpak; worked fine, I removed it afterwards since I decided to stay on stable.

Worth mentioning: I have tried removing and re-installing with reboots in-between for good measure, so far no luck.

gdb trace below:

(gdb) run
Starting program: /usr/bin/epiphany 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".
[New Thread 0x7fffea3ff640 (LWP 26367)]
[New Thread 0x7fffe9bfe640 (LWP 26368)]
[New Thread 0x7fffe93fd640 (LWP 26369)]
[New Thread 0x7fffe89ff640 (LWP 26370)]
[New Thread 0x7fffe3fff640 (LWP 26371)]
[New Thread 0x7fffe37fe640 (LWP 26372)]
[Detaching after vfork from child process 26373]
[New Thread 0x7fffe2bff640 (LWP 26374)]
[New Thread 0x7fffe15ff640 (LWP 26375)]
[New Thread 0x7fffe0dfe640 (LWP 26376)]
[New Thread 0x7fff99bff640 (LWP 26377)]
[New Thread 0x7fff993fe640 (LWP 26378)]
[New Thread 0x7fff98bfd640 (LWP 26379)]
[New Thread 0x7fff83fff640 (LWP 26381)]
[New Thread 0x7fff829ff640 (LWP 26382)]
[Thread 0x7fff829ff640 (LWP 26382) exited]
[New Thread 0x7fff829ff640 (LWP 26383)]
[New Thread 0x7fff821fe640 (LWP 26384)]
[Thread 0x7fff829ff640 (LWP 26383) exited]
[Thread 0x7fff821fe640 (LWP 26384) exited]
[New Thread 0x7fff821fe640 (LWP 26385)]
[New Thread 0x7fff829ff640 (LWP 26386)]
[New Thread 0x7fff819fd640 (LWP 26396)]
[New Thread 0x7fff811fc640 (LWP 26397)]
[Thread 0x7fff819fd640 (LWP 26396) exited]
[New Thread 0x7fff819fd640 (LWP 26398)]
[Thread 0x7fff811fc640 (LWP 26397) exited]
[New Thread 0x7fff811fc640 (LWP 26399)]
[New Thread 0x7fff809fb640 (LWP 26400)]
[Thread 0x7fff811fc640 (LWP 26399) exited]
[Thread 0x7fff809fb640 (LWP 26400) exited]
[Detaching after fork from child process 26401]
[Detaching after vfork from child process 26402]
[Detaching after vfork from child process 26406]
[Detaching after vfork from child process 26410]
[Detaching after vfork from child process 26413]
[New Thread 0x7fff809fb640 (LWP 26416)]
[New Thread 0x7fff811fc640 (LWP 26417)]
[Detaching after vfork from child process 26418]
[New Thread 0x7fff1ee52640 (LWP 26420)]
[Detaching after vfork from child process 26421]
[New Thread 0x7fff1e651640 (LWP 26423)]
[Detaching after vfork from child process 26448]
[New Thread 0x7fff1de50640 (LWP 26450)]

Thread 1 "epiphany" received signal SIGSEGV, Segmentation fault.
0x00007ffff041dd94 in wl_resource_get_destroy_listener () from /usr/lib/

Any help would be greatly appreciated. :slight_smile: Cheers.