Gnome-tweaks problem

Hi, I’m trying to install gnome-tweaks. I tried using sudo pacman install gnome-tweaks and it installed the 1.13 MiB file. But when I ran the gnome-tweaks command, this pops up:

WARNING : Error getting shell mode
CRITICAL: Error getting shell version
WARNING : Shell not installed or running
WARNING : Shell not running
NoneType: None
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/gtweak/", line 29, in do_activate = Window(self, model)
  File "/usr/lib/python3.8/site-packages/gtweak/", line 58, in __init__
  File "/usr/lib/python3.8/site-packages/gtweak/", line 107, in load_tweaks
    mods = __import__("gtweak.tweaks", globals(), locals(), tweak_files, 0)
  File "/usr/lib/python3.8/site-packages/gtweak/tweaks/", line 170, in <module>
    sw = StaticWorkspaceTweak(size_group=sg, loaded=_shell_loaded)
  File "/usr/lib/python3.8/site-packages/gtweak/tweaks/", line 46, in __init__
TypeError: 'GSettingsFakeSetting' object is not subscriptable

I also tried downloading the gnome-tweaks-git using the git URL. I was able to clone it, but when I ran makepkg -si in the terminal, this happens:

==> ERROR: Cannot find the fakeroot binary.
==> ERROR: Cannot find the strip binary required for object file stripping.

By the way, I’m using virtualbox for running Manjaro.
Please help me out. Thanks!! :smile:

Probably because you are trying to use gnome-tweaks on XFCE?

Is there a reason why you are trying to do that?

What is the output of:

pgrep gnome-shell


inxi -Fazy

1 Like

pgrep gnome-shell dosen’t return anything

Output of inxi -Fazy:

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=e6d5b7b7-936b-4f27-8f2e-10d9c44a1bb5 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Virtualbox System: innotek product: VirtualBox v: 1.2 serial: <filter> 
  Chassis: Oracle Corporation type: 1 serial: <filter> 
  Mobo: Oracle model: VirtualBox v: 1.2 serial: <filter> BIOS: innotek 
  v: VirtualBox date: 12/01/2006 
  ID-1: BAT0 charge: 18.5 Wh condition: 50.0/50.0 Wh (100%) volts: 10.0/10.0 
  model: innotek 1 type: Unknown serial: N/A status: Discharging 
  Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MCP 
  arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: N/A 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 10853 
  Speed: 2712 MHz min/max: N/A Core speeds (MHz): 1: 2712 2: 2712 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT Host state unknown 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Unknown: Dependent on hypervisor status 
  Type: tsx_async_abort status: Not affected 
  Device-1: VMware SVGA II Adapter driver: vmwgfx v: bus ID: 00:02.0 
  chip ID: 15ad:0405 
  Display: x11 server: X.Org 1.20.10 driver: vmware unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x974 s-dpi: 96 s-size: 508x257mm (20.0x10.1") 
  s-diag: 569mm (22.4") 
  Monitor-1: Virtual1 res: 1920x974 hz: 60 
  OpenGL: renderer: SVGA3D; build v: 2.1 Mesa 20.2.3 direct render: Yes 
  Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0 
  v: kernel bus ID: 00:05.0 chip ID: 8086:2415 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: kernel port: d020 
  bus ID: 00:03.0 chip ID: 8086:100e 
  IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge 
  driver: piix4_smbus v: N/A modules: i2c_piix4 port: d200 bus ID: 00:07.0 
  chip ID: 8086:7113 
  Local Storage: total: 20.00 GiB used: 8.12 GiB (40.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: VirtualBox model: VBOX HARDDISK size: 20.00 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: 1.0 scheme: MBR 
  ID-1: / raw size: 19.99 GiB size: 19.55 GiB (97.80%) used: 8.12 GiB (41.5%) 
  fs: ext4 dev: /dev/sda1 
  Alert: No Swap data was found. 
  Message: No sensors data was found. Is sensors configured? 
  Processes: 168 Uptime: 5m Memory: 3.84 GiB used: 911.9 MiB (23.2%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: 1115 pacman: 1112 
  lib: 349 flatpak: 0 snap: 3 Shell: Bash v: 5.0.18 running in: xfce4-terminal 
  inxi: 3.1.08 

Is gnome-tweaks not supposed to be run on xfse? I’m completely new to Linux. If I’m not supposed to use it, can you suggest an app for tweaking on xfse?

Gnome Tweaks is meant to be run on, as the name implies, Gnome. Not xfce. :slight_smile:

XFCE Settings has all the tweaks you should need.

1 Like

Haha my bad! So everything is in-built?

It was back when I used XFCE.

XFCE is very customizable, unlike Gnome, where they almost force you to use it the way they want.


Oh I see! Thank you so much for your help!! Really appreciate it! :smile:
@emke and @Strit Thank you for the responses!!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.