Gnome-Tweaks not persisting input settings after update in xorg

Hi there,

after the latest stable update to GNOME 3.38.1 / Manjaro 20.2 my Gnome Settings for Input (Keyboard/Mouse) are no longer persisted on Xorg.
This affects touchpad sensitivity, natural scrolling, mouse speed,…

Has there been any change here?

Might be the same problem as in Mouse Natural Scrolling Setting Not Persisting After Update.

Do I have to set every setting in /usr/share/X11/xorg.conf.d for a workaround?

Inxi-Dump:

System:    Kernel: 5.4.74-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: GNOME 3.38.1 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 9370 v: N/A serial: <filter> 
           Mobo: Dell model: 0F6P3V v: A00 serial: <filter> UEFI [Legacy]: Dell v: 1.13.1 
           date: 07/08/2020 
Battery:   ID-1: BAT0 charge: 38.1 Wh condition: 40.7/52.0 Wh (78%) model: SMP DELL G8VCF6C 
           status: Charging 
           Device-1: hidpp_battery_2 model: Logitech Wireless Mouse 
           charge: 55% (should be ignored) status: Discharging 
           Device-2: hidpp_battery_3 model: Logitech K520 charge: 70% (should be ignored) 
           status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A 
           L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
           Speed: 2532 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 2328 2: 2228 3: 2200 
           4: 2261 5: 2296 6: 2276 7: 2203 8: 2207 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:3 
           Display: x11 server: X.Org 1.20.9 driver: intel resolution: 1: 1920x1080~60Hz 
           2: 2560x1440~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.1 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.4.74-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
           vendor: Bigfoot Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel 
           port: f040 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
           bus ID: 2-1.2:3 
           IF: enp0s20f0u1u2 state: down mac: <filter> 
           IF-ID-1: br-9b11bf69cadf state: down mac: <filter> 
           IF-ID-2: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 261.33 GiB (54.8%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV512G NVMe 512GB size: 476.94 GiB 
Partition: ID-1: / size: 452.07 GiB used: 261.33 GiB (57.8%) fs: ext4 dev: /dev/dm-0 
Swap:      ID-1: swap-1 type: partition size: 16.64 GiB used: 0 KiB (0.0%) dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 54.0 C mobo: 37.0 C sodimm: 39.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 267 Uptime: 18h 24m Memory: 15.10 GiB used: 2.80 GiB (18.5%) Init: systemd 
           Compilers: gcc: 10.2.0 Packages: 1643 Client: shell wrapper v: 5.0.18-release 
           inxi: 3.1.08 
1 Like

Hello,

It never wrote any config for xorg but rather writes them in the DConf database

Quite possible to be the case of a slight bug, but maybe just a local issue.
Check with DConf Editor and look inside /org/gnome/desktop/peripherals/
Or use the /usr/share/X11/xorg.conf.d/40-libinput.conf as i mentioned in the other topic.

1 Like

Hi,

thanks for your quick answer :slight_smile:

My comment was somehow misleading, sorry.
What I meant is, that this is just happening when I use Xorg.

Anyhow, the DConf Settings seems to be fine, all dialogs show correct values, why the settings are not applied - I don’t know.

I will dig deeper into it when I’ve more time, the current workaround is fine for me.

Thx @bogdancovaciu

1 Like

Yeah, i noticed too some inconsistencies between X11 and Wayland sessions, but since i don’t have a laptop and my mouse works as i set it, can’t check more about this issue directly.

@Chrysostomus and @Ste74 - any idea about this ?

Ok, after some investigation I figured that the problem just occurs after resuming from standby on XOrg.

Therefore I removed a fix I did for my touchpad:

/usr/lib/systemd/system-sleep/fix-dell-touchpad

#!/bin/bash
case $1/$2 in
  pre/*)
    # echo "Going to $2..."
    /usr/bin/rmmod i2c_hid
    ;;
  post/*)
    # echo "Waking up from $2..."
    /usr/bin/modprobe i2c_hid
    ;;
esac

On my first observation that fixes the settings problem AND the fix might not be even necessary with kernel version 5.4.x