Gnome Tweaks not launching

Hi, I have an issue where Gnome Tweaks has stopped working suddenly.

When I try to launch it, I can see that the mouse cursor shows the ‘working’ icon, but nothing happens.

Any ideas how to fix this ?

Edit: Manjaro Unstable Branch, running Kernel 5.9.12-1

Thanks !

Open a terminal and paste the output of the following command in your post.


I think this could be related to the recent unstable update.

Here is the output:

~ >>> gnome-tweaks                                                             
Traceback (most recent call last):
  File "/usr/bin/gnome-tweaks", line 17, in <module>
    import gtweak
ModuleNotFoundError: No module named 'gtweak'


If you’ve upgraded python to 3.9, then your gnome-tweaks requires rebuild. An easy workaround is temporarily using gnome-tweaks-git from AUR instead.

1 Like

Thanks. Using gnome-tweaks-git from AUR worked.

Just did a rebuild and pushed 3.34.0-5 to unstable.


Thank you. Installed from Terminal and It works perfectly now.

However a strange new problem has cropped up - maybe totally unrelated but the Pamac GUI (add/remove software) is not launching. Just the busy cursor and nothing.


It is unrelated. See:

1 Like

Yup. Thank you.

That was my post you have linked :slight_smile:

It has since been solved as well.

Thanks a lot for the quick responses.

I loaded the new Gnome OS 20.2 and everything was working yesterday. Today suddenly everything has been crashing. Gnome Tweaks is bugged badly and can’t make anything black. Just the title bar!

Everything is pure white.

Uninstalling Gnome-Tweak and then installing AUR Gnome-Tweak fixed the situation though only after a complete reboot

This was also posted in Gnome Distro 20.2 Thread I made.

Just trying to help others.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.