GNOME shows some applications in dock as "Unknown" with default icon

Hello guys!

This is my first post, I hope you won’t eat me.
So today I dropped a full Manjaro update, over 300 packages were updated (if necessary I can post full list of upgraded packages).

During that I had to deal with some hickups related to NVidia 460xx drivers - I installed them manually a while ago and becouse of that pacman refused to perform update to 460xx, becouse “xxx already exist in filesystem”. I ended up removing all conflicting nvidia-related files from lib and lub32 directories.
Anyhow, after that I turned off my PC and went out. After I got back I launched my beast and noticed a “slight” problem.

Some applications when I launch them show up in dock with default icon (regardless what icon theme I use) and with name “Unknown” both when hovering over them in dock, in top panel and in Alt+Tab view.

For now I noticed this for:

  • Google Chrome (both stable and beta)
  • Caprine
  • Discord
  • Steam
    All of them are marked as favourite and pinned to my dock. Other apps open up normally, showing a dot under icon in dock, or if not pinned to dock open with normal name and icon from my icon theme.

I tried reinstalling them, reinstalling dash-to-dock, adding StartupWMClass both in /urs/share/applications/.desktop and ~/.local/share/applications/.desktop files. Nothing works. In other DEs - I tested XFCE and Cinnamon - there’s no such problem, only in GNOME. I also tried adding custom .desktop files with direct paths both to exec and icon from my theme - didn’t work.

Can somebody help me? It’s SUPER annoying, I value aesthetic in my system, so having four weird icons in my dock, right next to correct icons makes me hit the wall…

Also I have a laptop with Manjaro GNOME, same kernel, same version, same updates ran today - nothing’s wrong there, no such problem.

My specs, versions, all that stuff:
Manjaro 20.2.1-1
GNOME 3.38.3-1
Kernel 5.10 (yes, I tested 5.8 and 5.9, didn’t help)

If full list of upgraded packages is needed let me know.

Thanks for all help!

Hi! Try to check package integrity with pacman -Qk
Maybe some files are missing or corrupted

Did that, 0 files missing or corrupted. I noticed, that icons that shows with “Unknown” apps come from Adwaita theme, but they are lower resolution than normally.