GNOME shows Error Message after boot

Every time I boot my laptop, it shows a message “Oh no! Something has gone wrong. A problem has occurred and the system can’t recover please contact the system administrator.”

I’ve done some research but it seems like this is a problem that needs to be individually solved. I’ve been able to access TTY by pressing Ctrl alt F5 and have access to the command line.

How can I find out what went wrong and fix it?

Here is what I tried:
Disable all gnome extensions
Update with Pacman
Update Pacman Mirrors

can you boot normally into your system, or its get stuck on black screen?
and when did it started to appear? did you install something/ uninstall/ updated …etc?
if you can boot normally provide formated output from:
inxi -Fazy
you can search logs for errors:
journalctl --boot=0 --priority=3 --no-pager
and then try also with this:
journalctl --boot=0 --priority=5 --no-pager

I can boot into my system. However, GNOME shows this error message:
I have dual boot and Windows still works. I can switch to TTY commad line with CTRL+ALT+F5. Unfortunatley, this is no DE, so i cant take screenshots, scroll, or copy text, so sorry for the bad quality. Anyways, here is the first and second output of the commands you send me. The third one outputs so many lines so fast, that its impossible to capture that unless its really important.


Apperantly, I cant embed pictures yet, so here is a dropbox link for the four images:

My computer worked like 3 days ago, I havent done anythink (I think). If it’s not fixable, that’s fine. I have a backup but its like two weeks old, so I wouldnt prefer that. However since i have a command line saving all the stuff shouldnt be to hard.

ok so when youre in TTY try running this:
sudo systemctl restart gdm
and also try to post logs from this:
journalctl --boot=0 --priority=5 --no-pager
it looks like you have log spamming …

The first command makes the error screen reappear after a few seconds. The second command outputs a lot. I took a video and if you pause, you should be able to read it, there is some motion blurr, though. I still can’t add it to the post, same link as above:
You might not be able to see the text
online, downloading it improves the quality by a lot.

not much to see… but the command just showed logs you could use your down and up keys on your keyboard to go trough it… or just take a picture of them when it stopped, those were the last logs…
try running these commands:
pamac update - if you get any errors, take a picture
and take picture of these 3:
mhwd-kernel -li
mhwd -l
mhwd -li

Up and down keys scroll through last commands unfortunately. I’ve taken a picture of the latest things in the log though.

The Pacman update (i just assumed you mean sudo pacman -Syu, since pacman update is not a thing) only shows that something is newer than in the database for some reason.

The second command says that kernel is an invalid option, and I’ve posted the output of the last two.

you typed mhwd kernel -li, the correct command is:
mhwd-kernel -li - so post the output of it
and i meant pamac update not pacman … pamac vs pacman
to fix the newer than… run this command:
sudo pacman -Syyuu
reboot, maybe it will help

Run the three commands and posted the output. Still the same error after reboot. Sorry for not reading properly

I’ve tried changing the kernel in the grub menu when it first broke, didnt help.

thats ok… so did you run also this command:
sudo pacman -Syyuu
this command downgrades the mesa package , do after you run the command reboot and come back… and pay attention to the command, there are two ‘y’ and two ‘u’ … checked the logs and didnt find anything on those ‘device removed’ logs…

I did that. After the reboot the error was still there, so downgrading the package didnt fix it. If you want, i can run pamac update again to double check if the package is downgraded now.

if you really run the command it should fixed it, dont know why it didnt worked… we can try install a new kernel and reinstall graphic and see…
install kernel with this:
sudo mhwd-kernel -i linux517
uninstall graphics:
sudo mhwd -r pci video-linux
install them again:
sudo mhwd -i pci video-linux
run these commands after:
sudo update-grub
sudo mkinitcpio -P
systemctl reboot

And pay attention to the commands!!

I ran pamac update once again and it doesn’t show that the package is newer than, so that worked. I still get the initial error (Please contact system administrator etc), i double checked that. I added a picture of that.

I’m currently installing the kernel with the commands you send me

Ran the commands, no errors, i posted some of the output. I rebooted and got the same message once again. Other people who had the same problem said that that is a gnome issue and since tty still runs, could it be that the kernel is perfectly fine?
If there is no solution rn, I might be able to do a backup of the important data and reinstall manjaro, is it possible to keep the dual boot setup and not touch windows?

can you check with this command if youre running the 5.17 kernel:
uname -a

It is, 5.17.1-3. Added a picture

so try disabling extension with this:
gsettings set disable-user-extensions true
then reboot:
systemctl reboot

I tried that when it first broke, but i did it again now. Didn’t work

so try these commands:
rm -r ~/.config/dconf
rm -r ~/.local/share/gnome-shell
systemctl reboot

Both removed, rebooted, same error. Forgot to take a picture now the commands say no such file or directory, that’s a good sign I guess since that means the rm command worked.

try reinstalling these:
sudo pacman -S gnome-shell
sudo pacman -S gnome-session
sudo pacman -S gdm
systemctl reboot