Gnome settings interfere with KDE themes

Having Gnome I installed KDE. Unfortunately, it looks like Gnome theme interferes with my KDE theme settings. For example, very hard to read text on buttons or highlighted items (see the screenshot https://paste.pics/a4e0881af8809e6e4b68a86254e3b2e8). Changing KDE theme does not do anything to fix the problem.

I hope you dont have a lot of time invested in your install. It might be faster to delete and start over.

I would prefer not to re-install Manjaro completely because I did invest a lot of time in my install.

Then I would suggest removing all the gnome packages. Not sure how or what they are, but a mix of those two desktops inst a good thing imho.

Having multiple desktops installed is known to mess up some graphical settings. That is why it is recommended to create and use distinct users for separate desktops.

1 Like

:point_up_2: This, and ensure you don’t have one dark and one light theme icons installed. Because that’s what this looks like: trying to use a dark icon theme in a light DE theme…

1 Like

Yes, makes sense. But how to fix everything in my current situation? Maybe reset themes somehow?

Indeed, delete/backup the theme configurations, then log out and log back in.

cd ~/.config
mv gtk-2.0 gtk-2.0.bak
mv gtk-3.0 gtk-3.0.bak
mv gtk-4.0 gtk-4.0.bak
mv kdedefaults kdedefaults.bak

Not sure about the GTK+ list though.

If you want to remove gnome, here is a possible way. I am not sure it will get everything, but it should get rid of the majority of it. I highly recommend backing up with timeshift before doing this. If something goes fubar at least you will be able to get back to where you are now.

The command is sudo pacman -Rcns packagename this will remove the package and all its dependencies. You will have to replace packagename with the name of the package.

I create a Manjaro gnome spin, so I have a list of gnome packages. I am not sure if these are in your install, but its a minimum to try and remove.

gnome-session
gnome-settings-daemon
gnome-shell
gnome-control-center
gnome-desktop
gnome-disk-utility
gnome-keyring
gnome-online-accounts
gnome-screenshot
gnome-session
gnome-settings-daemon
gnome-shell-extensions
gnome-logs
gnome-system-monitor
gnome-terminal
gnome-tweak-tool

Tried, didn’t help.

Same issue for me. I had this line in /etc/environment:

QT_QPA_PLATFORMTHEME="qt5ct"

Commenting fixes my problems