Gnome Phavo Shows no Login Prompt, CTRL+ALT+F2 often doesn't show login prompt


I’ve attempted an install on my dual boot desktop system , with single external monitor a few times but I can’t get any stability with this issue whereby I can’t login to gnome and most of the time can’t CRTL+ALT+F2 or CTRL+ALT+F3 and so on to login to gnome by running startx or systemctl restart display-manger. Updating all packages and using the latest NVIDIA driver hasn’t helped so far either.

As I understand it this seems to be an issue GDM / NVIDIA or perhaps plymouth, wayland.

I’ve tried the solutions in the following threads (and probably more) to troubleshoot this and can’t seem to make any improvement.


So far I’ve tried these ISOs
and I’m currently on manjaro-gnome-21.1.3-210916-linux513.iso (Phavo)

I’ve run updates on all, and have interrogated systemd logs with journalctl but can’t seem to pin down the fix here.
Edit : No updates have been run yet on my current Phavo install as I’ve tried that and the issue seems to be with default settings from Phavo right up to latest stable update.

Hoping someone can assist me here?

See logs below
Edit : full manjaro-log-helper logs here Ubuntu Pastebin

inxi -Fza

System:    Kernel: 5.13.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 root=UUID=2fde8f71-c249-4bf0-8487-e14c2256ab1e rw quiet splash 
           apparmor=1 security=apparmor udev.log_priority=3 
           Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG STRIX Z370-G GAMING (WI-FI AC) v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 2801 date: 01/13/2021 
CPU:       Info: 8-Core model: Intel Core i7-9700K bits: 64 type: MCP arch: Kaby Lake note: check family: 6 model-id: 9E (158) 
           stepping: C (12) microcode: EA cache: L2: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 57616 
           Speed: 800 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
Graphics:  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: driver: nvidia v: 470.63.01 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1b06 class-ID: 0300 
           Display: server: 1.20.13 compositor: gnome-shell driver: loaded: nvidia resolution: <missing: xdpyinfo> 
           OpenGL: renderer: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           chip-ID: 8086:a2f0 class-ID: 0403 
           Device-2: NVIDIA GP102 HDMI Audio vendor: driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           chip-ID: 10de:10ef class-ID: 0403 
           Device-3: Creative Sound BlasterX G6 type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.4.2:12 
           chip-ID: 041e:3256 class-ID: 0300 serial: <filter> 
           Sound Server-1: ALSA v: k5.13.15-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.35 running: no 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: f000 bus-ID: 00:1f.6 
           chip-ID: 8086:15b8 class-ID: 0200 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: ASUSTeK driver: rtw_8822be v: N/A 
           modules: rtw88_8822be port: d000 bus-ID: 06:00.0 chip-ID: 10ec:b822 class-ID: 0280 
           IF: wlp6s0 state: down mac: <filter> 
Drives:    Local Storage: total: 6.83 TiB used: 8.41 GiB (0.1%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7 temp: 32.9 C 
           scheme: GPT 
           ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 26.9 C 
           scheme: GPT 
           ID-3: /dev/sda maj-min: 8:0 vendor: Toshiba model: HDWE140 size: 3.64 TiB block-size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: FP1R scheme: GPT 
           ID-4: /dev/sdb maj-min: 8:16 vendor: Samsung model: HD103SJ size: 931.51 GiB block-size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT 
           ID-5: /dev/sdc maj-min: 8:32 type: USB vendor: Transcend model: JetFlash Transcend 8GB size: 7.31 GiB block-size: 
           physical: 512 B logical: 512 B type: SSD serial: <filter> rev: 8.07 scheme: MBR 
Partition: ID-1: / raw-size: 64 GiB size: 62.44 GiB (97.57%) used: 8.31 GiB (13.3%) fs: ext4 dev: /dev/nvme0n1p2 
           maj-min: 259:3 
           ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p3 
           maj-min: 259:4 
           ID-3: /home raw-size: 186 GiB size: 182.02 GiB (97.86%) used: 102.3 MiB (0.1%) fs: ext4 dev: /dev/nvme0n1p4 
           maj-min: 259:5 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 43 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 19% 
Info:      Processes: 301 Uptime: 21m wakeups: 0 Memory: 15.57 GiB used: 2.54 GiB (16.3%) Init: systemd v: 249 tool: systemctl 
           Compilers: gcc: N/A Packages: pacman: 1101 lib: 285 flatpak: 0 Shell: Zsh v: 5.8 running-in: gnome-terminal 
           inxi: 3.3.06 

systemd-analyze blame

Generated on 2021-11-26 09:01:1637917308

#################### cat /var/log/Calamares.log ########################

=== START CALAMARES 3.2.40-4

=== START CALAMARES 3.2.40-4

#################### systemd-analyze blame ########################

1.501s plymouth-quit-wait.service
 640ms snapd.service
 410ms systemd-modules-load.service
 382ms tlp.service
 195ms dev-nvme0n1p2.device
 180ms systemd-random-seed.service
 167ms apparmor.service
 152ms user@120.service
 107ms boot-efi.mount
 103ms user@1000.service
  95ms lvm2-monitor.service
  73ms udisks2.service
  68ms ldconfig.service
  57ms polkit.service
  50ms systemd-udev-trigger.service
  44ms upower.service
  35ms systemd-rfkill.service
  33ms systemd-timedated.service
  29ms ModemManager.service
  27ms NetworkManager.service
  27ms systemd-udevd.service
  25ms systemd-journald.service
  24ms systemd-logind.service
  16ms systemd-vconsole-setup.service
  16ms plymouth-start.service
  15ms cups.service
  15ms systemd-journal-flush.service
  13ms plymouth-read-write.service
  13ms systemd-sysusers.service
  12ms systemd-fsck@dev-disk-by\x2duuid-0437\x2d1849.service
  12ms systemd-fsck@dev-disk-by\x2duuid-8fe56495\x2dc2b6\x2d4b31\x2db8b4\x2d7b1c90476282.service
  10ms systemd-tmpfiles-setup-dev.service
  10ms systemd-journal-catalog-update.service
   9ms systemd-tmpfiles-setup.service
   9ms modprobe@fuse.service
   8ms colord.service
   7ms gdm.service
   7ms accounts-daemon.service
   7ms snapd.apparmor.service
   6ms wpa_supplicant.service
   6ms dev-hugepages.mount
   6ms home.mount
   6ms ufw.service
   6ms dev-mqueue.mount
   6ms sys-kernel-debug.mount
   5ms user-runtime-dir@120.service
   5ms sys-kernel-tracing.mount
   5ms systemd-update-utmp.service
   5ms user-runtime-dir@1000.service
   5ms tmp.mount
   4ms kmod-static-nodes.service
   3ms modprobe@configfs.service
   3ms modprobe@drm.service
   3ms systemd-remount-fs.service
   3ms systemd-sysctl.service
   3ms alsa-restore.service
   2ms linux-module-cleanup.service
   2ms rtkit-daemon.service
   2ms systemd-user-sessions.service
   2ms systemd-update-done.service
   1ms sys-fs-fuse-connections.mount
   1ms sys-kernel-config.mount
 308us snapd.socket

I have tried to provide full logs but as a new forum account I can’t upload the full output of manjaro-log-helper nor provide links to a full log hosted elsewhere.
Appreciate any help that can be provided here as I’m stuck.

Edit : full manjaro-log-helper logs here Ubuntu Pastebin
Edit : Secure boot set to ‘Other OS’ in BIOS , Windows Hibernation / fast boot disabled on this dual boot system

1 Like

Solved by replacing GDM with LightDM and slick-greeter

We where talking in the team about your “solution”, and we are not quite into what you proposed.
Gnome installs now provide gdm-plymouth plus is enabled in /etc/mkinitcpio.conf in the HOOKS.
Personally i remove it from HOOKS and because i too have an Nvidia GPU i change the MODULES line like this

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

I install gmd without plymouth and then i run:
sudo mkinitcpio -P
sudo update-grub

Also, since some other changes the default /usr/lib/udev/rules.d/61-gdm.rules is creating a bit of hiccup. Is trying to prevent older Nvidia drivers to run wayland and restrict it to those from 470 above, but it actually preventing all, even 495 to actually work properly. So i changed from this:

# disable Wayland on Hi1710 chipsets
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", GOTO="gdm_disable_wayland"

# disable Wayland if modesetting is disabled
IMPORT{cmdline}="nomodeset", SUBSYSTEM=="drm", KERNEL=="card[0-9]*", GOTO="gdm_disable_wayland"

# Disable wayland when nvidia modeset is disabled or when drivers are a lower
# version than 470, in any case always prefer Xorg
KERNEL!="nvidia_drm", GOTO="gdm_nvidia_drm_end"
SUBSYSTEM!="module", GOTO="gdm_nvidia_drm_end"
ACTION!="add", GOTO="gdm_nvidia_drm_end"
# disable wayland if nvidia-drm modeset is not enabled
ATTR{parameters/modeset}!="Y", GOTO="gdm_disable_wayland"
# disable wayland for nvidia drivers versions lower than 470
ATTR{version}=="4[0-6][0-9].*|[0-3][0-9][0-9].*|[0-9][0-9].*|[0-9].*", GOTO="gdm_disable_wayland"


RUN+="/usr/lib/gdm-runtime-config set daemon PreferredDisplayServer xorg"

RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"


to the older rule, like this:

# disable Wayland on Hi1710 chipsets
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="/usr/lib/gdm-disable-wayland"
# disable Wayland when using the proprietary nvidia driver
#DRIVER=="nvidia", RUN+="/usr/lib/gdm-disable-wayland"
# disable Wayland if modesetting is disabled
#IMPORT{cmdline}="nomodeset", RUN+="/usr/lib/gdm-disable-wayland"

This way i do not have any hang, i still can use gdm and i can select X11 or Wayland.

Moreover, you have

and that is an EOL kernel. I suggest to switch to 5.15 and also give the latest nvidia driver a try, unless you are into some gaming and also use display port …
Also, i see that your machine is a Desktop, yet you have tlp installed. Remove it.

Hope this helps, so you don’t have to go on shady “solutions”.

1 Like