Gnome + optimus manager

Hello, I’m “fresh user” just moved from Linux mint and still testing Manjaro but have a question regarding Gnome and Optimus manager:

so…installed optimus manager+optimus manager qt from AUR and on XFCE working normal and my Nvidia looks like running normal but under Gnome there is problem. Instructions from terminal says to remove in one file “#” before Wayland…but not helps

is someone here for who optimus manager working normal or have a solution what to do under Gnome ?

the instructions on how to fix it foresee such an error … but why following the instructions cannot fix it …


see it and it.

In my case, I installed the Linux-numberkernel-bbswitch and Linux-numberkernel-acpi_call packages . I edited /usr/share/optimus-manager.conf and I changed the line to define bbswitch (I don’t use the nvidia card). I’m on Wayland session.

If you want to remove Wayland (used by default), you need to edit the /etc/gdm/custom.conf file and uncomment the WaylandEnable=false line. Restart the computer and choose gnome on xorg with the wheel icon on GDM screen.

ok, thank you but i noticed a few other annoying things in gnome … among others when i turn on the movie it’s like screen cuts along the screen as if half of the screen is out of sync with the other half…so think to stay with xfce, but thanks anyway