Gnome On Screen Keyboard not usable after 2021-04-09 update

Hi guys,

I’m having a problem after the stable update of 2021-04-09. It’s about the onscreen keyboard of my 2-in-1 HP Pavilion x2. I’m using Gnome with Wayland.

After the update, the onscreen keyboard doesn’t register any key other than the characters. So, no return, delete, etc, making it unusable. The problem is that I don’t even know where to start looking, since the keyboard is part of gnome.

Does anyone have an idea of where I should look in order to troubleshoot the issue? Which logs could have some info about it? I haven’t found much info on the internet about this in particular, and none of the replacements really integrate with the system in a satisfactory way.

Here’s my system’s info. I’ve tried to revert to kernel 5.9.16 to no avail.

System:    Kernel: 5.11.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: GNOME 3.38.4 Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion x2 Detachable v: Type1ProductConfigId serial: <filter> 
           Mobo: HP model: 813E v: 34.12 serial: <filter> UEFI: Insyde v: F.18 date: 01/22/2018 
Battery:   ID-1: axp288_fuel_gauge charge: 40% condition: N/A volts: 3.7 min: N/A model: N/A status: Discharging 
CPU:       Info: Quad Core model: Intel Atom x5-Z8300 bits: 64 type: MCP arch: Airmont rev: 3 cache: L2: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 11524 
           Speed: 510 MHz min/max: 480/1840 MHz Core speeds (MHz): 1: 510 2: 1306 3: 480 4: 480 
Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics vendor: Hewlett-Packard 
           driver: i915 v: kernel bus-ID: 00:02.0 
           Display: wayland server: 1.20.10 compositor: gnome-shell driver: loaded: i915 
           note: n/a (using device driver) - try sudo/root resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (CHV) v: 4.6 Mesa 21.0.1 direct render: Yes 
Audio:     Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit driver: N/A bus-ID: 00:03.0 
           Sound Server-1: ALSA v: k5.11.10-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.24 running: no 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: 1000 bus-ID: 01:00.0 
           IF: wlp1s0 state: up mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-3:2 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 146.14 GiB used: 42.26 GiB (28.9%) 
           ID-1: /dev/mmcblk0 vendor: Samsung model: BGND3R size: 29.12 GiB 
           ID-2: /dev/mmcblk1 model: SD128 size: 117.02 GiB 
Partition: ID-1: / size: 23.73 GiB used: 19.06 GiB (80.3%) fs: ext4 dev: /dev/mmcblk0p3 
           ID-2: /boot/efi size: 999 MiB used: 312 KiB (0.0%) fs: vfat dev: /dev/mmcblk0p1 
Swap:      ID-1: swap-1 type: partition size: 3.91 GiB used: 16.5 MiB (0.4%) dev: /dev/mmcblk0p2 
Sensors:   System Temperatures: cpu: 44.0 C mobo: 26.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 238 Uptime: 3m Memory: 1.86 GiB used: 1.45 GiB (77.9%) Init: systemd Compilers: gcc: 10.2.0 
           Packages: 1288 Shell: Zsh v: 5.8 inxi: 3.3.03

I’ve been digging a little deeper and apparently solved the issue (fingers crossed). Right now, the on-screen keyboard behaves as expected. Here’s what I did, I hope it helps anyone running into the same problem:

  • Journalctl showed a keyboard related problem with this text: “JS ERROR: Error: Argument wc:value is out of range for uint32”

  • A bit of research showed that this is related to gjs (Javascript Bindings for GNOME)

  • I downloaded and manually installed a previous version of gjs (from 1.68.0-2 to 1.68.0-1). Sadly, this broke many gnome elements that depend on gjs to function, so I was greeted with a “Unable to log in” screen.

  • I logged in a tty (Ctrl + Alt + F3) and installed gjs-git via pacman. Rebooted and faced the same screen. Then I installed gjs-dev through pacman. After a reboot, the system logged in correctly and the on screen keyboard works fine now.

  • Now, if I do a sudo pacman -Syu, I get the choice to change gjs-dev for gjs-git, which I haven’t done. It doesn’t seem to get in the way of any other update, so I’ll keep it this way.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.