Gnome-next, testers needed

I tried it… Seems it is not ready yet :slight_smile:

1 Like

Dont know is this a bug or no , but I will report :slight_smile:

As you can see, I have dark theme, but Manjaro settings is still white , and description is barely visible

Manjaro settings is a Qt application if I remember correctly, while your dark theme in Gnome is GTK.

For Qt apps in Gnome you have to use Kvantum themes.


You don’t have to, however it is an option that’s set as default in /etc/environment.

Since @brtza is using Adwaita, the best way is to not use QT_STYLE_OVERRIDE at all and let QGnomePlatform / AdwaitaQt do it’s magic. Just comment out this line and reboot:


Thanks, now it looks better :slight_smile:

I don’t want to be the bearer of not so good news, but I’m afraid there is still an undesirable behaviour with layouts switcher.

Whenever you’re switching from the Tiling layout to any other layout (I tested switching to the Manjaro and Gnome layouts though) the keyboard input stops working for me. I had to click Apply and then Reload desktop to get the keyboard input back up.

That does not happen switching among layouts other than Tiling. Just clicking Apply gets the job done and there is no need to Reload the desktop.

Note that I’m using wayland with open source video drivers (i915 modesetting + noveau).

I’m my opinion, I’m OK doing these 2 clicks to ensure proper layout switching. It might be not clear for everyone though.

Yep, this is exactly why there is the reload desktop button. With sweeping changes to enabled extensions, this always a possibility. Switching from material-shell to other layouts has always caused some kind of issues, they just vary from release to release. Nothing we can do about it, though it might eventually go away in a few years as material-shell gets developed. We could reload shell automatically, but it is unnecessary in most cases, and very distruptive on wayland, so I thought it best to leave the use of that button to user discretion.

1 Like

I installed Manjaro unstable with gnome-next on a vm.
It looks very modern, stable and usable.

but I found some minor issues:

In the Dack to Dock Extension:
The Icon Size Limit is acting weird.

If Location Services disabled:
click gnome-maps->Go to current location
In the Dialog the option Location Settings does nothing.

If Location Services disabled:
gnome-weather stuck on loading screen.


I don’t know if it’s still relevant for you, but:
according to Manjaro - Branch Compare Gnome 40 is available on Unstable.

If you talk that icons are small by default in the dock, you must check that the option “Fixed icon size: scroll to reveal others icons” is enabled. It solve the problem.

Hi, thanks for that info, but yes, I know that. Using it from unstable for longer period :slight_smile:

Manjaro development iso 202105310502 Live usb:

  • Manjaro Gnome layout switcher issues:

Switching Unity → Manjaro = Not OK.
Switching Titling → Manjaro = Not OK

Manjaro Legacy, Gnome, Traditional → Manjaro = OK but desktop icons stay after switching traditional to Manjaro.

Manjaro → Manjaro Legacy, Gnome, Traditional, Unity, Titling = OK.

Manjaro Legacy, Gnome, Traditional, Unity, Titling without Manjaro = OK.

2 solutions: 1. Remove Unity and Titling layouts. 2. Keep Unity and Titling layouts but Manjaro is greyed when Unity or Titling layout are enabled.

I will make more tests tomorrow and I will see if I’ve got the same problem when Manjaro Gnome-next is installed on HD.


Can you tell more about “Not OK”? Does the reload desktop button solve the situation?

Yeah it’s kinda complicated to design for. On one hand, desktop icons are really needed for the traditional and unity layout. On the other hand, we have a separate switch for desktop icons on the second page of the layout switcher, and the other layouts try to respect what the user has chosen there. So, the result is kinda inconsistent design.

Thank you for testing!

Would it be feasible to add a caption or something to layouts switcher to give a hint to the users so they reload the desktop if they find issues after switching?.

Something like this:

Hint: Click on the Reload Desktop button if you encounter issues after switching

I tested it all on todays build, didnt notice any issue.

It works as it should.

Still fee glitches here and there, with not ao smooth transition, but probably fixable. :slight_smile:

@Chrysostomus While using unity layout, In preview I have some kind of weird icon.

As you can see in picture attached, left is layout switcher and right is empty one ?

what is that ? :slight_smile:

@Chrysostomus: No problem to install the last development iso (20210531). No problem to make updates and install software.

I encountered some issues after install:

  1. I’ve got a laptop with a 1920x1080 resolution screen. The screen resolution is set correctly but I don’t see the searchbar when the applications are displayed (application button pushed). Whether under the ‘dash to dock’ extension , ‘dash to panel’ extension or with the default gnome desktop (vanilla) and under Manjaro, Manjaro Legacy and Gnome Layout. The desktop only display all applications and the preview screens, no searchbar. The Manjaro theme is defined by default.

  2. About the Manjaro Layout switcher.

Switching Unity Layout → Manjaro Layout: Ok, but Gnome Desktop message in the upper left screen stay and desktop icons stay.
Switching Titling Layout → Manjaro Layout, Manjaro Legacy Layout , Gnome Layout = That’s crap. Activities button is out of order and Application button is vanished.

Reload desktop button solve the situation.

Otherwise, it looks good working for the rest.


Note (2021/06/02): I had installed a previous version of the development iso on an other HD. The searchbar was available. I made the new updates today for that previous version, and the searchbar is still present. I don’t know why I haven’t got the searchbar for the applications with the development iso of 2021/05/31 ?

This is intentional, to leave more space for the workspaces. It is done by the ui-tune extension.


I thought it was a bug. It is after seeing the ‘Gnome 40 IU improved’ extension that I understood that the ‘Hide Search’ option is used to not display the application search bar. By default, it is activated. I think this search bar is essential, and I don’t understand why you disabled it. The search bar does not prevent to see the workspaces.
For me, the ‘hide search’ option should be disabled.

Otherwise, I tested the development ISO from 20210603 and except some issues with the Gnome layout switcher, I didn’t encounter problems.


  1. The search bar is not really useful. Search works without it and you never needed to click it to start the search.
  2. The desktop looks better with it.

Still, we probably have to consider the element of discoverability. That swarch bar can help people notice that there is indeed search there. We’ll consider adding it back.