Gnome Network Displays not connecting to microsoft wireless display adapter

I have tried both the Flatpak and AUR version and get the same error, it briefly shows a white screen on the display and then goes back to the connect screen. On my laptop it gives this error when running from a terminal before the connection timing out:

** (gnome-network-displays:4484): WARNING **: 14:08:29.939: Error initing screencast portal: Failed to create portal session (response: 2)

** (gnome-network-displays:4484): WARNING **: 14:08:29.939: Falling back to X11! You need to fix your setup to avoid issues (XDG Portals and/or mutter screencasting support)!

I tried posting this issue on their issue tracker but they told me to post it here first and closed the issue. If this is not a manjaro issue I’ll go back and ask again.

Well, can you blame them for closing the issue? :wink:

I see you’re using KDE with Wayland, perhaps that’s out of their scope. Notice the program name. :man_shrugging:

Sorry I couldn’t be more helpful. I’m the AUR package maintainer, but currently don’t have any cast devices to test with.

I’m not using wayland, just kde xorg. I haven’t found anything after a lot of googling which is why I asked in the first place.

Whoops, I had it backwards. Now I remember the Falling back to X11! message is normal if it doesn’t detect Wayland.

Right now I’m having yet another google session and I found a GitHub thread I don’t remember reading before (Error in Ubuntu 19.04 · Issue #19 · benzea/gnome-network-displays · GitHub) I’ll let you know if this fixes it

you can try launching with NETWORK_DISPLAYS_DUMMY=1 gnome-network-displays which provides a dummy sink to test.

Yes, I know. :wink:

Over 10 minutes later still nothing. The dummy sink doesn’t connect either, is it any different for you?

Dunno, I’ll try fiddling before I go to bed.

By the way, did you install xdg-desktop-portal-gtk or xdg-desktop-portal-kde?

yep, both are present on my system

No errors for me, but it perpetually stalls connecting to the dummy sink with the stable version.

I tried the development version and did see this, anyway:

** (gnome-network-displays:544876): WARNING **: 21:46:33.161: Cannot start streaming right now as we don't have a portal!

Perhaps install gnome-network-displays-git and see if you have more success.

same thing for the git version, it doesn’t give an error but stalls on connecting and then times out.