Gnome keyboard shortcuts broken after Tiling added

After the update to Nibia 20.2 and the addition of the tiling feature in Gnome (Pop!_shell) some of the gnome keyboard shortcuts are conflicting with the Pop_shell shortcuts.
Specifically Window Snapping. Ex: super + right arrow now conflicts with the keyboard shortcut in Pop!_shell for window focus.
I’m using the defaults for both. Am I missing something? Because this doesn’t seem like something the develops would just overlook. I miss my window snapping lol
Thanks for the help.

I run the default settings, and there is nothing as you describe, unless you had your own custom shortcuts. No conflicting shortcuts here.


I just reset my shortcuts to be sure they’re all default and I’m still having the same issue. I still can’t snap windows to right still. I’m just confused as to how i’m having this issue with the default settings. I tried to embed a picture to show the conflicting commands but it wouldn’t let me. My keyboard shortcuts are the same as you posted.

What package you have installed from this two:

I have pop-shell-shortcuts installed. I just checked using pacman -Qi

Install the other one and restart your session or reboot.

I’ve done a you said? I don’t any difference though. Do i have to do something else?

I can confirm I have lost the functionality of SUPER+L to lock the screen. It is still listed in settings/keyboard shortcuts, but something captures it. I am not sure how to call that, it simply shows the window that was activated immediately before currently active one.

1 Like

I have just now realized about this whole tiling thing. I can confirm the conflict with:



My productivity is cut in half without these. … I am also trying to understand some logic behind this tiling behaviour with super+arrow-keys and fail really to see any …So can’t even confirm or deny if they are working like intended …

Is it possible to switch this whole thing OFF for good?

EDIT: super+left-arrow still works as “view split on left”

EDIT: Tile windows applet says “Navigate windows super+arrow keys”. How is that not conflicting with previous gnome shortucts??

EDIT2: Also, there is no way to remove pop-shell-shortcuts, as far as I can see installing gnome-control-center-pop-shell-shortcuts will take pop-shell-shortcuts as a dependency and reinstall it again.

1 Like

Maybe is time to ping @Chrysostomus and @Yochanan as they for sure know more about this.
On my end the shortcuts work as i like them, exactly how my workflow is, and can’t reproduce any of the issues.

Yes, disable the pop-shell extension.

Thank you for reporting this issue. We’ll see what can be done about this.

The Pop Shell keyboard shortcut defaults remap some GNOME defaults, they don’t conflict with each other.

Default screen lock functionality is remapped to Super + Esc as H, J, K, and L are remapped to directional keys (aka Vim shortcuts) with Super as a modifier.

It seems the conflict is with your muscle memory. :wink: They take some getting used to, but if you don’t like them you can always remap them. Installing gnome-control-center-pop-shell-shortcuts will make customizing them easier.

We might have to map them elsewhere to not to conflict with defaults. Use wasd instead of hjkl?

I try always to be a dedicated default user and adapt to the given configuration. But, how come I still see in settings the old mappings :

super+arrow_left works, but
super+arrow_right/up/down they don’t
super+ESC+HJKL are not set anywhere

** I want to upload the screenshot (60KB jpg), but I’m getting error “cannot embed media”

I have disabled the Pop Shell extension and now it’s all fine again. Thanks!

Again, they don’t “conflict”, they remap defaults to their own.

:rofl: Nope. Vim users will revolt.

I don’t use Vim either, but I understand the logic of using those keys since they’re on the home row.

Folks, the “default” keyboard shortcuts for GNOME and Pop Shell are only suggested settings. If one does not like them, change them. Simple as that.

1 Like

There was just an update sent out today that seems to have removed to the tiling feature for me. This has fixed the gnome shortcuts for me.