Gnome keep showing gjs on top bar and gjs icon on dash to dock

hi everyone, i have some problem with gnome manjaro after update on 18 August gjs icon on my topbar and my dash to dock, image
im still new on manjaro, so if you can help me i will be thankfull

1 Like

Hello,
sorry, no solution, I only have the same problem.

When GNOME extension for Desktop Icons NG (DING) is enabled, a running process gjs is displayed in the Dock and in the top-bar.

This happens with the pre-installed Manjaro-curated set of GNOME extensions (I have no others installed) in all cases wether you enable the DING yourself or via the “Layouts” application (which in itself is a very nice application, thank you!).

My work around for now: I do not enable desktop icons :-/

1 Like

I found another work around: Do not use the Wayland session! Log off, in the login screen click on your user name once and choose “GNOME under Xorg” from the session menu (cog wheel in the bottom right corner of the screen) on the login-screen.
The DING extension runs OK under Xorg but displays the gjs-Stuff under Wayland.

Hint:
The session menu contains “Gnome” and “Gnome Classic” when you do not have Wayland enabled (e.g. via the “Layouts” app) which both run under Xorg. And it contains “Gnome” (then meaning “using Wayland”), “Gnome Classic” and “Gnome under Xorg” if you have enabled Wayland. My system is set to German locale, so the actual wording may be different.
Anyway, use the DING extension with Xorg display server to avoid the artifact gjs-processes displayed.