GNOME installer still doesn't work with NVIDIA graphics

Hello all!

This seems to be a known issue, but the “solution” posted in the linked thread was “switched to Fedora, now it works”. While that is kind of funny, it does not really help me.

When you try to run the Manjaro 20.2 GNOME installer (with proprietary drivers) on a sufficiently old NVIDIA graphics card, at the point where GDM should start, the screen instead hangs forever on a blinking underscore.

Is there a fix coming (or already out) for this, or should I just quit trying to combine NVIDIA and GDM?

I know I can run the Manjaro XFCE installer and then manually add GNOME without GDM (that is the setup on which I am writing this post), but various tools really want you to have GDM as your display manager.

My search so far indicates that this happens to people with different NVIDIA cards since 20.2. I am on an ancient GTX 460 that has served me faithfully on all other Linux distros (not a laptop). Full system specs are provided at the end of this post via pastebin.

Full system specs: System: -

Here is the output of

for x in $(ls /etc/X11/xorg.conf.d/); do echo -e "---$x---\n\n $(cat /etc/X11/xorg.conf.d/$x)\n\n"; done
for x in $(ls /var/log/ | grep Xorg); do echo -e "---$x---\n\n $(cat /var/log/$x)\n"; done
journalctl -b1 --no-pager --no-hostname

And since journalctl did not like that, I have also pasted the full output of

journalctl -b --no-pager --no-hostname

(-b with no arguments is the current boot). The file exceeds the maximum size of free pastebin pastes, so I have split it after the basic system comes up and before X stuff happens. Hopefully the first half is unnecessary, but I will link it for completeness.
Journalctl first half:
Journalctl second half:

I have Nvidia GPU and none of the installers hangs at any point with the proprietary drivers.
Maybe you have a particular Laptop with hibrid graphics and maybe GDM is more peculiar with that?

That is interesting. I have updated my original post with the full system specs.

I am not on a laptop, and a quick Google search does turn up quite a few other people experiencing the same problem (with no solution).

On an unrelated note, the people on this forum are incredibly helpful and nice, that is wonderful!

Hello @BettaGeorge :wink:

Interessting would be some log:

for x in $(ls /etc/X11/xorg.conf.d/); do echo -e "---$x---\n\n $(cat /etc/X11/xorg.conf.d/$x)\n\n"; done
for x in $(ls /var/log/ | grep Xorg); do echo -e "---$x---\n\n $(cat /var/log/$x)\n"; done
journalctl -b1 --no-pager --no-hostname


I have updated my original post with links to those logs (it is kind of annoying that I have to sneak them past the forum software).

Journalctl did not like the “-b1” parameter, so I have also pasted the complete journalctl of the live boot. Apparently X cannot find my monitor?

PS: I probably should have mentioned in the original question – if I run the GNOME installer with the free drivers, it refuses to boot at all. That is why I tried the proprietary drivers, which at least gives me a running Manjaro, albeit without graphics.

Hi @BettaGeorge :slight_smile:

Both times in Xorg logs you start with

[    50.122] (II) NOUVEAU driver 
[    50.122] (II) NOUVEAU driver for NVIDIA chipset families
Fatal server error:
[    50.123] (EE) no screens found(EE) 

and gnomeshell fails because no drm device is available:

Dec 29 13:14:42 gnome-shell[1384]: Failed to create backend: No drm devices found

Seems you didn’t start with the nvidia driver or at least the included nvidia driver does not support your gpu and fallback to nouveau.

Since kernel 5.9 older drivers has been dropped. 455xx, 450xx and 390xx for legacy are only supported now. I would suggest to install it with the LTS Kernel, which should have a driver for your gpu:

The only difference is here the kernel and the driver support. Everything else is the same.

1 Like

Ah, that makes sense, thank you! That also explains why that problem suddenly appeared with the new versions.

Yes, the nouveau drivers have never worked for my card, I just didn’t notice they were the fallback. I’ll try the LTS version and report back, then probably mark this as solved.

The problem remains unchanged even with the LTS version.

I am soon heading back to i3, so this is not a big problem for me, but it is still puzzling.

@BettaGeorge Sorry i was wrong…:

$ LANG=C pamac list -g linux54-extramodules | grep nvidia
linux54-nvidia                   [Installed] 455.45.01-6      extra  21.6 MB
linux54-nvidia-390xx                         390.138-2        extra  11.0 MB

All other driver version than 455, 450 and 390 has been dropped everywhere.

So you have to use the nouveau driver if it does not work.

What let me think is this:

[    50.657] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=de tz=UTC misobasedir=manjaro misolabel=MANJARO_GNOME_202 quiet systemd.show_status=1 driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1

Especially this: driver=nonfree nouveau.modeset=0

[    50.663] (EE) Failed to load module "nv" (module does not exist, 0)

So did you ever try boot with free drivers?

I have tried the free drivers, it refuses to boot at all, just presenting me with a blank screen and endlessly idling fans.

So it is the same behavior on nouveau and nvidia? Then I doubt it tries to load nouveau…


nouveau.modeset=0 <- block nouveau (set it to 1)

also change driver=nonfree to driver=free manually.

I believe there is a wrong configuration on the ISO.

No, the behavior is different.

Free (I assume nouveau?): does not boot

Proprietary: boot goes fine, but X fails to start.

So one gives me a running Manjaro, the other does not.

Can I edit the settings you mentioned in the boot options?

  1. Go to the menu entry which starts Manjaro and type e
  2. Edit the boot parameter manually and boot with F10

Thanks, I’ll try that.

The ISO seems to be fine, however, setting nouveau.modeset=1 results in a failure to boot no matter the other boot options.

I fear this might not be solvable without major tinkering, so I guess the canonical solution is “do not run GNOME on outdated NVIDIA GPUs”.

I’m having the same issue but on a Nvidia Geforce GTX 1050. It might not be the newest, but I’d not call it outdated. I think there is a bigger problem. Can anyone provide any more insights?

For reference: I did get the installer working using the free drivers.

It is strange that the live environment starts up with the non-free drivers, but then the installed environment does not.

Totally forgot to update this topic. End of the story: I never did get it to work and ended up buying a new graphics card.